Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #28101

    Hi Guys and Gals,

    I suspect it might be that I’ve too many images uploaded to my gallery but either way, I’m unable to view them in any list form now (which means I can’t change the order, set custom attributes etc.).

    The landing page is http://www.justinfryer.com/wp2013/?page_id=323

    It’s password protected as it contains photos of my wife, daughter, other family etc. – please reply to this thread privately and I’ll provide the password accordingly…

    The point is: when in the Admin GUI, I can upload photos fine but then NOT change the order after saving changes – it just shows an empty page…

    I’ve tried different browsers (Firefox, IE, Safari), different platforms (PC and Mac) – but no joy.

    Thanks!

    Justin

    #136477

    Hi Justin,

    With WordPress 3.6 it is now mandatory that you update your theme to get things working properly. Since you are on Flashlight 1.4 you’ll actually be seeing a completely re-done gallery which came out in 2.0.

    With the old version there is actually no ability to sort galleries at all so you’ll need to update for both 3.6 and to get control over your galleries.

    Regards,

    Devin

    #136478

    Hi Devin,

    Thanks for your reply and I actually happened to update/upgrade to 3.6 anyhow. This was to see if it would rectify the issue – unfortunately, it didn’t.

    Come to think of it, I may not have explained the issue properly so I’ve taken some screenshots to aid your diagnosis.

    Essentially, I’m able to view the images uploaded to the various galleries in all but my Family section.

    Here’s evidence of the problem in the Family section: https://dl.dropboxusercontent.com/u/23864537/Empty%20gallery%20-%20family%20photos.JPG

    And here’s evidence of what it looks like in another fully-functioning galler, this time Flying: https://dl.dropboxusercontent.com/u/23864537/Populated%20gallery%20-%20flying%20photos.JPG

    Without the ability to see the files, I’ve now way of re-ordering how they’re listed, crucially.

    Thanks,

    Justin

    #136479

    I should also add that I was previously able to access the gallery listing for my Family section up until recently when I added another tranche of photos. Is there a tipping point, from which things corrupt/stop working/break?

    Thanks,

    Justin

    #136480

    Hey,

    You have thousands of images in there. Please try to add this on your wp-config.php:

    define('WP_MEMORY_LIMIT', '256M');

    Contact your host, make sure that you are allowed to exceed this memory usage.

    Regards,

    Ismael

    #136481

    Ok, will do and after that I’ll let you know how it works out. What’s perculiar is that it was working before… even with the thousand (singular) amount of images.

    Thanks,

    Justin

    #136482

    Hey,

    Please let us know if it works.

    Regards,

    Ismael

    #136483

    Hi Ismael,

    That’s the line added to my wp-config.php. I’ll contact my hosting company and ask them to confirm if I’m allowed to exceed the memory usage as you suggest.

    I wasn’t sure where exactly to place the line so I inserted it just before the end. As such, it looks like:

    /**

    * WordPress Localized Language, defaults to English.

    *

    * Change this to localize WordPress. A corresponding MO file for the chosen

    * language must be installed to wp-content/languages. For example, install

    * de.mo to wp-content/languages and set WPLANG to ‘de’ to enable German

    * language support.

    */

    define (‘WPLANG’, ‘en_US’);

    define (‘FS_METHOD’, ‘direct’);

    define(‘WP_DEBUG’, false);

    /* That’s all, stop editing! Happy blogging. */

    /** WordPress absolute path to the WordPress directory. */

    if ( !defined(‘ABSPATH’) )

    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */

    require_once(ABSPATH . ‘wp-settings.php’);

    define(‘WP_MEMORY_LIMIT’, ’256M’);

    ?>

    #136484

    Just tried reloading the page, flushed the DNS, etc.

    No joy, still the same problem.

    Crikey, I’m beginning to wonder if I need to rebuild the entire page now… say it aint so!!

    #136485

    Hey Justin,

    You missed the main part of my original response: you **must** be using the newest version of the **Flashlight** theme if you are using WordPress 3.6.

    The version you have, 1.4: http://www.justinfryer.com/wp2013/wp-content/themes/flashlight/style.css , is **not** compatible with WordPress 3.6 and with it you are **not** able to re-order galleries and things like that.

    So before doing anything else please re-download the theme files from your downloads on Themeforest and install the updated theme files.

    For a quick guide on updating your theme take a look at this video on updating the Enfold theme via FTP: https:/vimeo.com/channels/aviathemes/67209750

    Regards,

    Devin

    #136486

    Hi Devin,

    You’re quite correct and apologies for that – I’ve been on flying duties over the past few days too, so I’ve not had a chance to read your post until now.

    Will duly head off and update the Flashlight theme pronto!

    Thanks again,

    Justin

    #136487

    Hi Devin,

    Hurrah! The problem seems to have been eradicated by means of two actions.

    Firstly, I updated the theme via the FTP method, as per your suggestion. Believe it or not, the problem was still there but I can now manipulate the order by virtue of the basic listing of the photos within the Page, Edit function (it provides a simple list which you can change by means of single left clicking the mouse and dragging a photo up or down the order). Even for a workaround, I was happy enough with that.

    However, I then also started then removing a few of the photos (there are an awful lot, I know) and now I can see the gallery listing as per the way it used to:

    https://dl.dropboxusercontent.com/u/23864537/Populated%20gallery%20-%20family%20photos.JPG

    Between the two steps, I’m obviously happy to be back with the full functionailty.

    You may close the call now and thanks again for all your help.

    Justin

    #136488

    Hey,

    Glad it is working now. :)

    Cheers,

    Ismael

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Unable to sort images uploaded to gallery…’ is closed to new replies.