Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #8701

    I have place a

      in a sidebar by using the text/HTML widget. The

      does not appear as a list, no bullets, just lines of text. Other HTML elements display correctly. Is this a CSS issue? Or is the UL tag not supported in the sidebar?

    Here’s one of the pages:

    http://www.clcschool.org/wp/?page_id=273

    The code in the sidebar is simple, it’s just this:

    During the 2010-2011 school year:

    • Student enrollment: 45 full-time students and 5 part-time students
    • Churches represented: 16 in Tompkins and Cortland counties
    • School districts served: Dryden, Cortland, Ithaca, and Lansing
    • Instructional class sizes: between 3 and 10 students.
    • Students who received financial aid: 11

    #62142

    I have the same issue.I want to have a services list in sidebar but there are no bullets.

    #62143

    Hey,

    try to add following code to css/custom.css:

    .sidebar .widget li a{
    color:#333;
    border-bottom:1px solid #e1e1e1;
    }

    .sidebar .widget li{
    background-image: url(../images/skin1/menu_arrow.png);
    background-position: -20px -10px;
    background-repeat: no-repeat;
    background-color: #333;
    }

    .sidebar .widget li{
    clear: both;
    float: left;
    margin: 0;
    width:100%
    }

    .sidebar .widget li{
    padding: 3px 0 3px 23px;
    display:block;
    }

    .sidebar .widget li a{
    display:block;
    }

    #62144

    Didn’t work for me.

    #62145

    Can you post a link please (and include the code I posted above)?

    #62146

    Currently our site is local.I copied the code you gave to custom.css (http://imageshack.us/photo/my-images/18/codeti.jpg/)

    The code i include in the text/html sidebar is the following: http://imageshack.us/photo/my-images/201/widgete.jpg/

    This is what you see though : http://imageshack.us/photo/my-images/214/listsidebar.jpg/

    #62147

    Didn’t work for me either. Live in-progress site is here:

    http://www.clcschool.org/wp/?page_id=272

    #62148

    Please add the code to css/custom.css otherwise I can’t investigate why it doesn’t work….

    #62149

    I did. Here’s how my custom CSS file looks now:

    /* Have fun adding your style here :) – PS: At all times this file should contain a comment or a rule, otherwise opera might act buggy :( */

    .entry-content ul, .entry ol{

    border-top: none;

    }

    body{ color: #444; background: #fff; }

    .sidebar .widget li a{

    color:#333;

    border-bottom:1px solid #e1e1e1;

    }

    .sidebar .widget li{

    background-image: url(../images/skin1/menu_arrow.png);

    background-position: -20px -10px;

    background-repeat: no-repeat;

    }

    .sidebar .widget li{

    clear: both;

    float: left;

    margin: 0;

    width:100%

    }

    .sidebar .widget li a{

    padding: 3px 0 3px 23px;

    display:block;

    }

    #62150

    I changed the code above a bit. It should display fine now. You can use any background-color (I chose #333) for the list icons.

    #62151

    Ok,i changed the code to custom css with the changed one you gave us but no luck.

    This is what i saw at first: http://imageshack.us/photo/my-images/204/clipboard03xl.jpg/

    Then i changed background color of widget .li to #FFFFFF and width to 90% and now see this: http://imageshack.us/photo/my-images/849/clipboard02hf.jpg/

    #62152

    Its not working for me either, but the new code doesn’t look any different than what was there previously. The sidebar does not seem to recognize the unordered list at all, it just displays it as body text. No bullets, no styling. It picks up other HTML elements like headers, but not the UL. I don’t understand why it would display some but not others.

    #62153

    OK, I just found that removing the

    <ul> tag causes the bullets to appear (in FF and Chrome) but does not apply the styles from the main CSS or the custom CSS. Font formatting tags also have no effect.

    #62154

    I hadn’t checked this for a long time.I followed Lance’s advice removing the ul tag but nothing happened.Site is online now and you can check it: http://www.minosnet.gr

    The sidebar is not on the main page but on the other you can see how it looks.

    I want to find a solution for this.I have updated to the latest version of propulsion theme and it didnt fixed this.

    Any suggestions?

    edit: It seems that opera and chrome shows the bullets but firefox and ie dont.

    edit2: I am using propulsion theme.

    #62155

    Hi Minosnet,

    In the HTML you put into the text widget, do you start it with “ul” or just do “li” for each item?

    Regards,

    Devin

    #62156

    I’ve tried both but it seems to work without the ul tag but only in opera and chrome.

    #62157

    Hi Minosnet,

    Lets try targeting your widget directly and then forcing the bullets to show:

    #text-3 {overflow:visible !important;}

    Add that to your css.

    Regards,

    Devin

    #62158

    Thanks Devin, that worked fine!

    Now i can see the bullets in every browser i tested.

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘unordered list not displaying correctly in sidebar’ is closed to new replies.