Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21567

    Getting some plain plain code on the top of the page

    class=”home blog logged-in admin-bar no-customize-support”> (when logged in, this text displays on the top of the page)

    class=”home blog”> (When not logged in)

    Here is the screenshot:

    http://tomkennyjapan.com/wp-content/uploads/2013/03/1.png

    http://tomkennyjapan.com/wp-content/uploads/2013/03/2.png

    Please suggest a fix. No code altered other than reducing the padding and margin of the menu items.

    Thanks

    #112268

    Hi tomkennyjapan,

    Try disabling any active plugins you have installed. It looks like there is something incorrectly closing or opening a tag early and its causing the issue you are seeing.

    Regards,

    Devin

    #112269

    Hi Devin,

    Here is the header.php

    <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Strict//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd”>

    <?php global $k_option, $query_string; $k_option = $query_string; ?>

    <html xmlns=”http://www.w3.org/1999/xhtml”>

    <head profile=”http://gmpg.org/xfn/11″>

    <!– basic meta tags –>

    <meta http-equiv=”Content-Type” content=”<?php bloginfo(‘html_type’); ?>; charset=<?php bloginfo(‘charset’); ?>” />

    <?php

    if (function_exists(‘khelper_follow_nofollow’)) khelper_follow_nofollow();

    // outputs a rel=follow or nofollow tag to circumvent google duplicate content for archives

    // located in framework/helper_functions/lots_of_small_helpers.php

    ?>

    <!– title –>

    <title><?php if (is_home()) { bloginfo(‘name’); ?><?php } elseif (is_category() || is_page() ||is_single()) { ?> <?php } ?><?php wp_title(”); ?></title>

    <!– feeds and pingback –>

    <link rel=”alternate” type=”application/rss+xml” title=”<?php bloginfo(‘name’); ?> RSS2 Feed” href=”<?php bloginfo(‘rss2_url’); ?>” />

    <link rel=”pingback” href=”<?php bloginfo(‘pingback_url’); ?>” />

    <!– stylesheets –>

    <link rel=”stylesheet” href=”<?php echo bloginfo(‘template_url’); ?>/js/prettyPhoto/css/prettyPhoto.css” type=”text/css” media=”screen”/>

    <link rel=”stylesheet” href=”<?php bloginfo(‘stylesheet_url’); ?>” type=”text/css” media=”screen” />

    <?php $skin = $k_option != ” ? $k_option : 1; ?>

    <link rel=”stylesheet” href=”<?php echo bloginfo(‘template_url’); ?>/css/style<?php echo $skin; ?>.css” type=”text/css” media=”screen”/>

    <!– scripts –>

    <?php

    // check which slider and which config file should be used

    if ($k_option == 1)

    {

    if($k_option == 1)

    {

    $config_url = get_bloginfo(‘template_url’).’/slideshow/dont_edit.php’;

    }

    else

    {

    $config_url = get_bloginfo(‘template_url’).’/slideshow/config.xml’;

    }

    ?>

    <script type=”text/javascript” src=”<?php echo get_bloginfo(‘template_url’); ?>/slideshow/js/swfobject/swfobject.js”></script>

    <script type=”text/javascript”>

    var flashvars = {};

    flashvars.xml = “<?php echo $config_url; ?>”;

    var attributes = {};

    attributes.wmode = “transparent”;

    attributes.id = “slider”;

    swfobject.embedSWF(“<?php echo get_bloginfo(‘template_url’); ?>/slideshow/cu3er.swf”, “featured_image”, “940″, “420″, “9″, “expressInstall.swf”, flashvars, attributes);

    </script>

    <?php } ?>

    <!– Internet Explorer 6 PNG Transparency Fix for all elements with class ‘ie6fix’ –>

    <!–[if IE 6]>

    <script type=’text/javascript’ src=’<?php echo get_bloginfo(‘template_url’); ?>/js/dd_belated_png.js’></script>

    <script>DD_belatedPNG.fix(‘.ie6fix’);</script>

    <style>#footer .box ul li a, #sidebar .box ul a {zoom:1;}</style>

    <![endif]–>

    <?php

    ######################################################################

    # PHP scripts

    ######################################################################

    // single post comment reply script by wordpress

    if ( is_singular() ) wp_enqueue_script( ‘comment-reply’ );

    // cehck for custom widgets

    check_custom_widget();

    //wp-head hook, needed for plugins, do not delte

    wp_head();

    ?>

    <!– meta tags, needed for javascript –>

    <meta name=”autorotate” content=”<?php echo $k_option;?>” />

    <meta name=”autorotate_duration” content=”<?php echo $k_option; ?>” />

    <meta name=”temp_url” content=”<?php echo get_bloginfo(‘template_url’); ?>” />

    </head>

    <?php

    ######################################################################

    # check for custom logo

    ######################################################################

    if (isset($k_option) && $k_option != ”)

    {

    $logo = ‘'.get_settings('home').'‘;

    $logoclass = ”;

    }

    else // default logo

    {

    $logo = get_bloginfo(‘name’);

    $logoclass = ‘logobg’;

    }

    ######################################################################

    # check if front page or subpage and apply class to body

    ######################################################################

    $k_page_id = ‘subpage’;

    $k_body_class =”;

    if (is_home()){ $k_page_id = ‘frontpage’; }

    if (isset($k_option) && !empty($k_option)) $k_body_class = ‘fullwidth’;

    ?>

    <?php body_class($k_body_class);?>>

    <div class=’wrapper’>

    <div id=”top”>

    <div id=”head”>

    <h1 class=”logo ie6fix <?php echo $logoclass; ?>”>/”><?php echo $logo; ?></h1>

    <?php

    // Menu Controlled by the Backend

    wp_nav_menu( array( ‘menu’ => ‘First’, ‘menu_class’ => ‘nav’, ‘echo’ => true,

    ‘fallback_cb’ => ‘displayfallbackSlider’, ‘before’ => ”, ‘after’ => ”, ‘link_before’ => ”, ‘link_after’ => ”,

    ‘depth’ => 0, ‘context’ => ‘frontend’, ‘walker’ => new description_walker() ));

    function displayfallbackSlider(){

    global $k_option;

    if(is_object($k_option)) $k_option->display(‘Menu Manager’,'show_main_description’);

    }

    ?>

    </div> <!– end #head –>

    #112270

    I’m not seeing any errors in the file alone but if you have any plugins active they can alter the live code of the header and we wouldn’t be able to see it in the header file alone.

    Additionally, make sure you are using the latest version of Display :http://www.kriesi.at/support/topic/latest-theme-updates-please-check-if-yourre-using-an-outdated-theme-version

    If we can see the site live they would also help.

    Regards,

    Devin

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Unwanted code output on top of the page: class="home blog logged-in admin-bar no’ is closed to new replies.