Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
  • #22576

    I upgraded the theme and then woocommerce today. I got the following error on all products pages

    Warning: uasort() [function.uasort]: The argument should be an array in /home/bozosqld/public_html/wp-content/plugins/woocommerce/woocommerce-template.php on line 795

    the product information box and tabs are not displaying.

    I noticed in another thread that there is a newer version of Abundance 1.91. I downloaded the latest on themeforest and it is 1.9. I need a quick fix as this is a live site.

    I have the problem of time difference. I am in Australia. I made a complete backup of the website prior to the upgrade just in case something went wrong.

    Hopefully I hear back from you before having to restore the site using that backup and redoing the upgrade tomorrow when I have a fix.

    Thanks in advance.


    Hi again

    I’ve just noticed that Product has disappeared from the backend menu. I can’t see any of those options including add a new product, categories, attributes. I also can’t edit any existing product.



    Hi Sharon,

    Deactivate all other plugins besides WooCommerce and see if that fixes the issue.

    When you updated WooCommerce, did you do the database upgrade when prompted? Are you also running wordpress 3.5.1?




    Hi Devin

    I’m running the latest wordpress. I deactivated the other plugins no difference.

    Any other ideas?




    Abundance 1.9.1 is compatible with the latest version and probably something went wrong during the update. Try following: Deactivate all plugins (incl. WooCommerce), then connect to your server (via ftp) and delete the wp-contentthemesabundancewoocommerce-config folder. Then unzip the themeforest zip file (make sure you downloaded the latest version from ) and upload the woocommerce-config folder into the wp-contentthemesabundance folder. Then activate WooCommerce and check if the problem persists.


    Hi Peter,

    The download file says 1.9 not 1.9.1. Could this be the issue?

    Where can I get 1.9.1?

    In the meantime I have restored the website with the backup I made prior to the upgrade. I will try again tomorrow with the right file.




    There is no version 1.91 as of yet. The correct version is always the one available on If you read about 1.91 in another thread then it was a mistake since there are two dozen themes, and sometimes even the support team makes a mistake, accidently looking at a different theme perhaps or mistyping.

    Also what you originally posted is not an error but a warning, which is very different. Please make sure that the setting below is just like this:

    define('WP_DEBUG', false);

    in your wp-config.php file at the root of your wordpress installation.




    I decided to try the upgrade again today. I know it’s been a couple of months but since this is a live site and the site owner is a nervous guy I waited.

    The site has been updated to 1.9 Abundance and wordpress 3.5.2

    Once again it’s the same issues.

    The first

    Warning: uasort() [function.uasort]: The argument should be an array in /home/bozosqld/public_html/wp-content/plugins/woocommerce/woocommerce-template.php on line 795

    the product information box and tabs are not displaying.

    But I have narrowed the down this first issue by deactivating all plugins and its with the Woocommerce Product Enquiry plugin that causes this error. So for the moment I have left this deactivated until I can find a solution.

    But the backend menu still has the issue of no longer displaying the Products menu item including Add Product, Categories, Tags, Shipping Classes & Attributes. So I can’t access any product page or any category etc. When I’m on a product page there is no Edit Product showing in the admin bar. Under the WooCommerce menu item, Orders & Coupons are not showing.

    I also tried Peter’s suggestion with no change.

    I would appreciate some urgent help with this.

    I did make a complete backup of the website prior to doing these upgrades so I can restore it to how it was. But I would prefer to fix the problem.

    Thanks in advance.


    You can fix the Woocommerce Product Enquiry issue by downloading the latest version from

    But the backend menu still has the issue of no longer displaying the Products menu item including Add Product, Categories, Tags, Shipping Classes & Attributes.

    It would be interesting if this is a theme related issue. Please try to switch to another theme (I’d recommend to use the standard theme Twentytwelve) and check if the issue persists…


    Hi Peter I already have the latest version and the Product Enquiry still exists.

    But more importantly I was doing as you suggested and switch to Twentytwelve but that broke the site. I now have this error

    Warning: require(public_html/wp-content/themes/twentytwelve/framework/php/function-set-avia-frontend.php) [function.require]: failed to open stream: No such file or directory in /home2/bozosqld/public_html/wp-content/themes/abundance/framework/php/inc-autoconfig.php on line 137

    Fatal error: require() [function.require]: Failed opening required ‘/public_html/wp-content/themes/twentytwelve/framework/php/function-set-avia-frontend.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home2/bozosqld/public_html/wp-content/themes/abundance/framework/php/inc-autoconfig.php on line 137

    I logged on to the server and deleted the Twentytwelve but I still have the error.

    Unless you have a quick fix I’m going to have to restore the site to before the update earlier today.




    Are you using any cache plugins on the server? It seems like something tries to load theme files (abundance/framework/php/function-set-avia-frontend.php) even if you activate another theme.

    Best regards,



    Hi Peter

    I fixed that fatal error by removing the .htaccess file and once I got the site back I put it back and that worked.

    And no I am not using a cache plugin with this theme because it doesn’t really work that well. But I did have code in the config file relating to the abundance theme which I have now removed. That would have been the issue.

    Any other ideas why I would have the issue with the theme and woocommerce?

    I have another version of this website using Replete and everything works fine. I am using all the same plugins and no issue.

    I have been using abundance for close to 2 years and I have never had a major issue before.

    I have deactivated all the plugins with no change.

    I appreciate the help.

    Thanks again.


    I have tried everything suggested and I can still not find the source of the problem.

    Hoping someone can help. Happy to provide login details.

    Thanks in advance.



    Please sent me an email with admin credentials to usjahm (at) gmail (dot) com . Please reference this post url.




    Thanks for the reply NIck.

    I have emailed admin detail




    I looked and your problem is that your wp installation is running at 40 megs while each of your pages takes around 70megs p3 plugin tells me. I sent you instructions regarding what to put where.




    I replied to the email with the instructions.

    I did as suggested. I also contacted Hostgator and they did the following:

    “As the memory limit variable was actually decreasing wordpress’s available memory, I have removed it, allowing wordpress to use up to 256M of memory per instance. “

    But the problem still exists.

    I’m not sure what to do now.

    Any guidance would be greatly appreciated.

    Thanks in advance.



    Well a memory boost sure did something positive

    old –

    new –

    The number of database queries went up 30% for some reason. weird. But that don’t matter since overall load time and WooCommerce monopolization of memory fell.

    As I wrote you, I don’t see anything disappearing or any visual problems from poking around. Can you clear your browser cache or tell me what to look for please.




    Thanks for all your help.

Viewing 19 posts - 1 through 19 (of 19 total)

The topic ‘Upgrade error’ is closed to new replies.