Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #14998

    Hi

    I have the flashlight theme and are building a site to sell high res photos via the woocommerce downloads method.

    These forums have been a big help (40 pages later I’m almost ok!)

    First let me say I am a comple noob at any coding, I know nothing :). Some guys at work have shown me how to connect to my domain and FTP and stuff though :)

    My host has a 7MB limit (mentioned on the gallery uploads page), but if I try to upload more than a 3MB file I get the following error Fatal error: Maximum execution time of 30 seconds exceeded in /home/burtonimagery/burton-imagery.com/wp-includes/media.php on line 258.

    This error occurs via the green button gallery upload, and on the woocommerce product page (product data section-> upload a file).

    I contacted my host (dreamhost.com), and they said this error actually doesn’t have anything to do with the file size limit

    The error is being given because the upload is going too slowly, all scripts have a time limit on how long they can run.

    They suggested uploading these files with a standalone FTP client likeFileZilla!. I have been able to connect to my FTP via filezilla.

    My question is:

    1. where do I put the image on my FTP so that I can then choose it in the theme?

    I can navigate through ‘name of my website.com/wp-content/uploads/2012/08, and see all the other images I’ve been able to upload via the gallery. Is that where I put it? But I tried this, but the file I put there isn’t in my media library in the theme (on the LHS panel, or in the woocommerce ‘upload a file’ -> media library option

    2. Do I need to do these steps to see the file??? http://www.kriesi.at/support/topic/how-to-use-the-%e2%80%9cmedia-gallery%e2%80%9d-images-in-combination-with-flashlight

    I don’t want to continue much further until I know I’ll be able to sell downloads of a high quality!

    thanks

    Rebecca

    #85820

    Hi Rebecca,

    First of all, you should contact your webhost. They are the people who can help you with the “MAX EXECUTION TIME ERROR”, as they have the control over it. As for your questions, You don’t need to ftp for the image, once the error above is resolved. You can just add it via Media > Add New or use woocommerce option to upload the file, in your case, it didn’t show up because of the error, and uploading the image/file is not successful. Hope this is helpful.

    Regards,

    Ismael

    #85821

    Thanks

    Back to plan B…. I contacted them and they said I would have to edit the .php file myself (bit beyond me and they warned it wouldn’t be supported by them).

    So I’ll finish builidng my site and will then install a plugin like http://wordpress.org/extend/plugins/add-from-server/ – that way if something isn’t working anymore I’ll know it’s the plugins fault!

    Unless you can suggest a better plugin???

    Thanks anyway.

    #85822

    Hi burtonimagery,

    Just a secondary option to consider is to create a new folder on your server via FTP to hold all of your high res images. Then just use a lower resolution image optimized for web when creating and adding product images. You should be able to upload these without issue and it will improve the general speed of the site.

    Then, you just put in the url to the photo download into the woo commerce field for it. This way wordpress doesn’t have to be involved with upload or managing your actual product photos and its just you+FTP.

    Regards,

    Devin

    #85823

    Hi Devin

    That sounds perfect, but I can’t get it to work?

    Here’s the steps I’m performing, the issue is that the url I use isn’t found when I try to download the product bought.

    I’m sure I am so close to getting this right and just needs some tweaking from you!

    1. I opened my ftp via dreamhost.com, but I can’t see a way to create a new folder… so I connected to ftp via filezilla and created a new directory … I wasn’t sure where I had to put it so I made two: I made one at the top level, so now there is burton.imagery.com, Logs, Maildir, and test…. and then I double-clicked burton.imagery.com and created a directory called testing. MY CONCERN is that when I open ftp via dreamhost again, I DON’T see the test or testing directories that I created.

    2. I used filezilla to put an image into three different directories (again because I’m not sure where the folder should be for it to work)… test, testing, and uploads/2012/08.

    3. I right-clicked on the image, and selected ‘copy urls to clipboard’

    4. I then went to a product I’ve already created in woocommerce, and in the Product Details ‘file path’ section I did as you suggested and pasted the url (if I clicked upload -> url instead, when I added the url in the url field a red X displayed next to it, so I know something is wrong).

    Now, this pasted the following, depending on which directory image I used….

    ftp: (Email address hidden if logged out) /test/IMG_8870.jpg

    ftp: (Email address hidden if logged out) /burton-imagery.com/testing/IMG_4578.jpg

    ftp: (Email address hidden if logged out) /burton-imagery.com/wp-content/uploads/2012/08/IMG_4578.jpg

    I checked with the I.T guy at work, and he said I just need to use the end bit, as it’s just a direct link to the image e.g. burton-imagery.com/testing/IMG_4578.jpg.

    THE ISSUE: No matter which url I use, part of or all of it, when I buy the image and open the link, it doesn’t prompt me to download, it prompts with a ” what do you want to do with ?email=my email@yahoo_com&order=order50205…:If I select ‘open’ it opens a new webpage with ‘file cannot be found’, and if I select ‘save as’ it displays the save dialog with the file name that isn’t a jpeg so won’t save email=myemail@yahoo_com&order=order_50205cf517e1c&download_file=740

    Thanks

    Rebecca

    #85824

    Hi Rebecca,

    First, talk to Dreamhost and ask where and how to create a folder on your site that you can access via FTP and see via the Dreamhost FTP program. It may just be a user permissions level but it is a good idea to check with your host just case (before you get too far).

    Second, the URL for the downloadable image needs to be one you can put into your navigation bar in any browser and access as well. So:

    http://burton-imagery.com/testing/IMG_4578.jpg

    or

    http://burton-imagery.com/wp-content/uploads/2012/08/IMG_4578.jpg

    Regards,

    Devin

    #85825

    THANK YOU DEVIN!!!!

    I’m in business :)

    Dreamhost sorted out the visablity of my folders, and your tip about the http:// worked

    I’ll create an FYI post for other beginners trying to sell their pics via download… pass on my learnings :)

    #85826

    Yay! Glad I could help!

    Hope you make lots of sales :)

    Regards,

    Devin

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Upload via FTP, workaround for max execution time error’ is closed to new replies.