Tagged: ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #12997

    I have created a website for a customer on my own webspace with the Abundance theme. Now that the site is complete and the customer is happy with it, I need to migrate it to their own domain.

    For some reason when I export the SQL database from my own domain’s phpMyAdmin then try to import it in phpMyAdmin on their domain, it will only upload properly if I DON’T change all instances of “www.mydomain.com” to “www.theirdomain.com”. In my experience in the past importing “dummy” dumps for templates I’ve purchased at Template Monster, you need to change the domain in the SQL file they provide.

    Is this not how you do it with Theme Forest/Other themes?

    If I do change the domain in the SQL file from mine to theirs it just won’t import, I get a myriad of “duplication” errors.

    Can you tell me why this is and how I should be migrating the site from one domain to the other, please? I’ve never had this problem before.

    FYI – The process I’m undertaking when trying to setup my customised Abundance theme on my customer’s domain is:

    > Setup MySQL database/user/etc in customer’s C-Panel

    > Install WordPress

    > Install Abundance

    > Install WooCommerce

    > “Import Dummy Data” in Abundance Theme Options

    > Upload via FTP my reconfigured Abundance theme files (copied from reconfigured site on my FTP)

    > Upload via FTP my reconfigured WooCommerce files (copied from reconfigured site on my FTP)

    > Upload via FTP my “uploads” folder from “wp-content” (copied from reconfigured site on my FTP)

    > [Attempt to] Import SQL exported from my domain (this only works if I leave my own domain URL unchanged in the SQL file which, as you can imagine, causes a million headaches on the customer’s domain and when I attempt to change the URLs manually it eventually bombs the whole reconfigured Abundance layout)

    Don’t know if this might help but another thing I noticed: When I do all of the above on my customer’s domain I noticed in their phpMyAdmin that several of the tables I have at my end don’t populate on theirs once I’ve installed Abundance and WooCommerce. All of the tables after “wp_woocommerce_termmeta” are missing (i.e. wp_wpsc_also_bought, wp_wpsc_cart_contents, wp_wpsc_checkout_forms, wp_wpsc_claimed_stock, wp_wpsc_coupon_codes, wp_wpsc_currency_list, wp_wpsc_download_status, wp_wpsc_meta, wp_wpsc_product_rating, wp_wpsc_purchase_logs, wp_wpsc_region_tax, wp_wpsc_submited_form_data).

    I was supposed to have the new site uploaded to my customer’s domain several hours ago, so any help would be highly appreciated.

    With Thanks,

    Nicole

    #77444

    Please try to import your sql file before you install everything on the client server. Try to:

    > Setup MySQL database/user/etc in customer’s C-Panel

    > Import SQL exported from my domain with changed url address

    > Install WordPress

    > Install Abundance

    > Install WooCommerce (not needed because SQL file data already exists)

    > “Import Dummy Data” in Abundance Theme Options (not needed because SQL file data already exists)

    > Upload via FTP my reconfigured Abundance theme files (copied from reconfigured site on my FTP)

    > Upload via FTP my reconfigured WooCommerce files (copied from reconfigured site on my FTP)

    > Upload via FTP my “uploads” folder from “wp-content” (copied from reconfigured site on my FTP)

    #77445

    Hi, I have the same problem. But I followed the incorrect WordPress guides :(

    When exporting the Database from my server, do I need to change each url linking to my domain?

    Because I have two kinds of urls:

    (12, 20, 0, ‘/home/studiob/domains/studiobuitenhof.com/public_html/wp-content/themes/coherence/includes/loop-comments.php::31′),

    (1861, 451, 1, ‘http://www.studiobuitenhof.com/2012/06/’),

    The second one is the normal url, but the first is from my root and is only theme related for as far as I can see in my database.

    Do I need the change the url of the first one to http://www.newdomain.com also or differently?

    > Setup MySQL database/user/etc in customer’s C-Panel

    > Import SQL exported from my domain with changed url address

    > Install WordPress

    > Install Abundance

    > Install WooCommerce (not needed because SQL file data already exists)

    > “Import Dummy Data” in Abundance Theme Options (not needed because SQL file data already exists)

    > Upload via FTP my reconfigured Abundance theme files (copied from reconfigured site on my FTP)

    > Upload via FTP my reconfigured WooCommerce files (copied from reconfigured site on my FTP)

    > Upload via FTP my “uploads” folder from “wp-content” (copied from reconfigured site on my FTP)

    So I need to do a clean install and setup of WordPress and the theme first after uploading the database before I re-upload the copy on my server?

    Thanks.

    #77446

    Hi,

    1) Try to export in utf8 and make sure the client mysql is also setup the same way, and that both wp-config.php files match. If you had them blank in yours then dont change just make sure that your client’s sql server is using the same encoding type a your server (swedish or latin is default i think)

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', 'utf8_general_ci');

    2) make sure that both wp-config files use the same prefix for tables in wp-config.php

    $table_prefix  = 'wp_'; //or whatever prefix you chose, as long as they match

    3) make sure that the user is the same on both the blogs, so if yours is admin, make sure that’s what the client site user is called.

    4) make sure that when you edit the sql export file to change the url and the path, that you use a proper editor and not just notepad.exe on windows or its equivalent on mac/linux. You must save the file in correct character encoding. Something like http://www.editpadpro.com/editsql.html that before saving asks you for encoding type to save in. and when you open a file shows you the current encoding type. This is the cause of many problems during a move.

    5) You should (a) import the database. (b) ftp all the files. (c) go to the admin section and resave the permalinks.

    6) Before you export the sql, go to Settings > General on your site, and change both urls to the way it will be on the client site. (step 4 should make this step redundant for the url)

    7) Change your Settings > Permalinks to default. and save before you export sql. after import on client side, add the permalinks back to the way you want them.

    8) Change this line (absolute path) to reflect the location on your client’s server.

    (12, 20, 0, '/home/studiob/domains/studiobuitenhof.com/public_html/wp-content/themes/coherence/includes/loop-comments.php::31'),

    remember that there is a difference in forward and backward slashes between windows and linux. To find out what the path on your client server, create a file called test.php and upload it to the base wordpress directory. and open it with browser – http://www.your-client.com/test.php Inside the file put

    <?php
    $p = getcwd();
    echo $p;
    ?>

    And you will replace this part ”/home/studiob/domains/studiobuitenhof.com/public_html/’ with whatever the above code tells you is the equivalent on your client’s site.

    Thanks,

    Nick

    #77447

    Hello,

    Before doing all the manual labor don’t forget that you are using WP ;)

    http://wordpress.org/extend/plugins/duplicator/

    I have used this plugin before without any problems but please take note that it’s still in beta stage so

    use it with caution..

    Regards,

    WarriorSan

    #77448

    I have good success with the backupbuddy plugin from ithemes. its pricey but after trying every other solution (also the manual way, which killed my settings for the abundance theme) it allows me to upload a perfect clone of my dev environment.

    #77449

    Hi!

    Thanks JackVa for your input :)

    Regards,

    Peter

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘URGENT: Importing SQL Database’ is closed to new replies.