Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #2338

    I’m having a really bad experience with the portfolios… almost to the point of giving them up now…

    1. In my portfolio section (at: http://onexhub.com/portfolio-2/) the READ MORE button has incorrect URL. Instead of having a URL like “website.com/category/portfolio/post-name” the [Read More] button has url of the portfolio page gallery like “website.com/portfolio-2″.

    In the “Portfolio Options” of Avisio, I have [Portfolio Image Link]=”Show Portfolio Single Post”… and what’s strange is that the [image URL] in the portfolio gallery is CORRECT, whereas the [Read more] buttons URL is incorrect (for 2 out of 3 of the portfolio entries).

    2. Also, clicking on any of the portfolio items produces a “Page Not Found” error. It works perfectly fine when I set permalinks to “default”, but setting the permalinks to anything else will produce 404.

    I have tried flushing permalinks, fiddling around with web.config, and I have read just about anything that has anything to do with permalinks in this forum, but nothing helps. ONLY the permalinks to the portfolio pages are broken. All other permalinks on the website works JUST FINE!

    Would it be possible to give you an admin account so you can sort things out?

    #37625

    Please don’t post the same question twice. You can bump your post but don’t create new threads for the same question. I closed your other post here: http://www.kriesi.at/support/topic/permalink-problem-only-with-the-portfolio-page

    You can send me your login details to: (Email address hidden if logged out)

    I can’t promise that I can help you though. A habitat user had the same problem three weeks ago and I couldn’t find the problem. Maybe it’s a hoster related thing.

    #37626

    I’m really sorry about the double post. I appreciate your having a look at the problem. I would gladly have a go at it myself if you can point me in the right direction. I am no stranger to coding as I have been developing for 13+ years in ASP, though I am quite new to PHP and wordpress.

    I have sent the login info… hope you got it…

    Notwithstanding the permalink problem, the [Read more] issue is quite puzzling, because only the [Read more] url is incorrect –hovering the mouse over the featured picture will show that the url for the portfolio permalink seems to be fine.

    I am hosted at Godaddy.com using IIS7… but I think the problem is somewhere in the theme codes. I was thinking of fiddling with the web/config to correct the permalink issue –try to rewrite/redirect a portfolio pretty url into the “ugly url” using the web.config.

    This is the only thing remaining to be fixed in this setup, so hopefully you will be able to find the offensive code or at least be able to explain to me your thoughts on this problem so I can debug the problem even with my very little knowledge of php.

    Thank you for the assistance.

    #37627

    i’m having a similar issue. please post the solution. thanks.

    #37628

    My email to rhoel – maybe it helps you:

    1) I changed the permalink structure. The old one was

    /%year%/%monthnum%/%day%/%postname%/ – I changed it to /%category%/%postname%/ and now it works. I’m not sure which variable is causing the error though (it must be year, month or day because I’m using postname too).

    2) To use the read more buttons correctly, you need to create an excerpt text. The excerpt field can be found in your portfolio entry editor.

    #37629

    Strange that the excerpt needs to have a value for the [read more] to work… I guess it should be a required field to avoid the same problem for other people.

    Dude, I really sincerely appreciate the help, thank you very much!

    #37630

    Thanks. What about this issue: http://codex.wordpress.org/Using_Permalinks

    “Starting Permalinks with %category% is strongly not recommended for performance reasons.”

    #37631

    You can remove it from your link structure if you like. I didn”t notice a performance problem though (I tested several configurations). Maybe you need several (i.e. 100+) posts to experience a performance problem. I didn’t test it personally.

    #37632

    Dude, I tried your suggestion of /%category%/%postname%/ and am still getting the problem. It works when I use the default structure i.e. http://74.220.216.216/?p=123.

    But that is not what I want due to SEO considerations and I expect to have more than 100 posts. I would like the structure: /%year%/%category%/%postname%/

    My portfolio page is here: http://74.220.216.216/ask-a-lawyer/

    When I click on a portfolio item it takes me to “/category/portfolio/”and then the page name i.e http://74.220.216.216/category/portfolio/severance-package-review/

    It appears as though the portfolio item will always fall into the “/category/portfolio/” directory regardless of what the custom permalink structure is.

    Any suggestions?

    #37633
    #37634

    I resolved my issue.

    I had a problem with my .htaccess file.I edited the file by deleting the wordpress portion. I then logged into my wordpress control panel and then defined my permalink structure again. everything is working now:)

    See http://codex.wordpress.org/Using_Permalinks for editing htaccess file

    #37635

    Glad that you solved the problem.

    #37636

    I’m experiencing the same issue. The ‘Read More’ links correctly only when I’m using the default permalinks. I have tried everything in this post without success. Please advise

    #37637

    Hi jogwu78,

    Have you checked that your permalinks work under the other configurations for other pages in the site? IE, when you set it to something other than the default settings, can you go to a page link and it show up properly?

    Can you provide a link to your site so we can take a look as well.

    Regards,

    Devin

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘URGENT! Portfolio Read More button has incorrect link’ is closed to new replies.