Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #15613

    We use our portfolio primarily for videos, embedded from vimeo.com. We have to use the iframe embedding because we have a fair amount of mobile users. Most of the traffic to our site is for video viewers, therefore this is a big problem. Whenever you visit a portfolio page in firefox or safari, you can’t full screen the video. In safari, the video gets stuck inside the preview image box. In Firefox, it always defaults the vimeo “auto-scaling” to off. Google Chrome seems to work fine. I’m using a Mac, haven’t had the chance to test this problem on PC.

    http://fwcflorence.com/portfolio/spirit-conference-2012-night-1-rev-reggie-scarborough/

    For that post, my embed code looks like: iframe src=”http://player.vimeo.com/video/47738925?title=0&byline=0&portrait=0″ frameborder=”0″ webkitAllowFullScreen mozallowfullscreen allowFullScreen /iframe (i excluded the < >)

    I’m using the Fade Slider and the “Use Slideshow” option. I want to have a preview image and using the slideshow is the only way to get the preview image and the video to work together. The mobile player on iPhones and iPads works fine. Just these few browsers.

    Please let me know if you need any more information. In advance, thank you for your help.

    #88230

    Update: This blows my mind. On my macbook laptop, screen resolution of 1440×900, the video goes to full screen properly. However, iMacs with resolutions of 1920 x 1200 and 2560 x 1440 don’t work.

    #88231

    It’s not possible to open an embedded video as fullscreen video. The user must click on the cross in the right bottom corner which tells the vimeo player to switch to the fullscreen mode. You can try to use prettyphoto as workaround – add an image link to the post/page content and point the url to the vimeo video.

    #88232

    I realize they can’t open an embedded video as fullscreen video. The page loads like normal & when you click play, the video starts normal, in it’s normal place, not full screen. However, when a user clicks on the cross in the bottom right corner of the video, the video gets lost in the “preview image” box as it tries to go full screen. Sometimes it just disappears. Please advise.

    #88233

    Hi FWCMedia,

    I suspect it has something to do with your iframe code/embed url. In Firefox, Chrome and IE on a PC I get Scaling set to off by default and have no trouble opening the video in fullscreen.

    Regards,

    Devin

    #88234

    Has anyone else had this problem? While Kriesi is in update mode, I investigated this further because I was going to suggest that he work on an update for this. However, as I went to recreate the problem, it seems to be resolved. I’m wondering if it was a vimeo issue all along, and they fixed it on their end. Thoughts?

    #88235

    Hi!

    Hm, from what I have read here this seems to be something vimeo related. I have done quite a few fixes with the last patch but none that would effect the vimeo fullscreen mode…

    Best regards,

    Kriesi

    #88236

    I have the same problem but it is on the home page slider, when I use the Image Size Options and set it to Big Image/Video, the video plays inside the frame and I see the controllers but they do not work, I cannot go to youtube or vimeo or go to full screen, or use the volume control etc. I am still developing locally so I cannot give URL yet

    #88237

    Hi!

    Are you using the latest version of the theme? (we released an update yesterday, to version 1.6)

    Best regards,

    Kriesi

    #88238

    yes I just updated to the latest version and it is still doing it. The same thing is happening on your live demo of the theme. You can see it here:

    http://www.kriesi.at/themes/choices/2011/01/28/another-title-for-our-pretty-cool-blog/

    As you can see, the vimeo controls do not work

    Thanks!

    #88239

    Hi!

    Please try to add following code to css/custom.css:

    .slideshow_container.bottom_shadow{
    display: none !important;
    }

    Probably this will fix the issue.

    Regards,

    Peter

    #88240

    Nope that did not fix it.

    #88241

    Hi,

    Either one of these should do the trick

    .bottom_shadow img {display: none !important;}

    or

    .bottom_shadow{z-index: 1 !important;}

    Thanks,

    Nick

    #88242

    Both of those gave me access to the youtube control bar, that all works great now except for the full screen button, that one does not work at all with either of them.

    Any ideas?

    Thanks!

    #88243

    Vimeo fullscreen controls work great but youtube’s did not.

    #88244

    Hi,

    I can’t find any youtube videos on your site to test it out. On demo I don’t see any problems though.

    Thanks,

    Nick

    #88245

    I am developing locally still so I cannot give you a URL

    When I post it on a staging site I will give you a URL so you can see the problem.

    Thanks

    #88246

    Hey!

    Great. Post the link when you’re ready.

    Regards,

    Peter

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘Vimeo Full Screen problems in Portfolio’ is closed to new replies.