Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #175512

    Hi,

    I was trying to clean up the demo pages but got this error message after deleting some of the pages.

    Warning: Invalid argument supplied for foreach() in /home/content/…/config-templatebuilder/avia-shortcodes/postslider.php on line 443

    The tags are gone as well.

    Does this have anything to do with the demo pages I deleted?

    thanks,

    #175513
    This reply has been marked as private.
    #175521

    Hi,

    Now that issue is solved. I figured it was a conflict between the “portfolio” name I used in the Theme setting and a page of the site. The both shared the same name, “course”. After changing the portfolio name to something else, now the tags are back and the postslider is displaying portfolio again.

    The new problem is, clicking on any of the portfolio item takes me to an error 404 page not found page. I used the same “portfolio name” for both English and Chinese version of the site. Not clear if should use different names or doesn’t matter.

    Can you please help take a look?

    Thank you,

    #175523

    Hello!

    Please try to flush the permalinks (go to Settings > Permalinks and click the blue button to save the permalink rewrite rules).

    Cheers!
    Peter

    #175527

    Peter,

    How are you doing? thanks for chiming in.

    I updated the permalink structure, cleared cache, result is the same. Can’t get to the portfolio page.

    Thanks,

    #176212

    Hi!

    Please try this plugin to repair the database: http://wordpress.org/plugins/wp-dbmanager/

    Regards,
    Ismael

    #176237

    Ismael,

    Would this work with wordpress 3.6.1? It was last updated in April.

    Now the issue is can’t get to the portfolio item page. So you think the database is messed up and using this plugin to repair the db would fix the issue?

    thanks,

    #176239
    This reply has been marked as private.
    #176240

    Hi,

    did a “repair database” but portfolio is still not accessible. Same “Error 404 – page not found”…

    Thanks,

    #176365

    These are the permalink settings of our site:

    Common settings: post name
    Optional: none selected
    Product permalink base: default

    Is it okay that I have nothing configured for the optional settings? I did notice there are many settings in the Optional section, do I need to add anything here?

    Please help me as now there is no access to the portfolio items. :(

    thank you,

    #176366

    I did try to switch back to the default Common Settings, checked the portfolio items, all worked and were accessible. Switched back to Post name, got the error 404 page again…

    Using the default settings, the portfolio URL would read something like “?portfolio=” while using the post name based permalinks, the portfolio URL would read “/course-portfolio/”. “course-portfolio” is the name I configured in the Enfold theme settings. I used the “course-portfolio” for both English and Chinese version of the site.

    thanks,

    #176926

    Hi!

    Please create us an admin account and we’ll look into it.

    Best regards,
    Peter

    #177204

    I have tha same problem.

    #177775

    Hi!

    Please post your login details here. Set it as a private reply so you and only moderators can see it.

    Best regards,
    Ismael

    #177962
    This reply has been marked as private.
    #178015

    Hi!

    Problem was caused by the WPML String translation plugin.

    Cheers!
    Peter

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Warning: Invalid argument supplied for foreach() in … postslider on line 443’ is closed to new replies.