Viewing 30 posts - 1 through 30 (of 38 total)
  • Author
    Posts
  • #20958

    Before I post my issues with the updates and issues doing a fresh install of both the theme and woocommerce I wanted to check and see if you are aware of the even new Woocommerce Version 2.0.2.

    I was prompted to update from V 2.0.1 to V 2.0.2 this afternoon.

    Are you aware of the newest Version from today?

    #109787

    I’ve already done a partial update with the WooCommerce, and it threw a couple of kinks into things. I have misc page numbers under the product sliders on the frontpage, I now have sort features under the Headings for products on the fornt page, and even the product images I upload now appear disturbingly blurry. =(

    Everything was going so well!!! =P

    #109788

    Your best bet to disable all your plugins with the exception of woocommerce and go to themeforest and download the theme update again, there was a little confusion yesterday but the correct versions are now listed there.

    Try doing the theme update again with the new download and disabled plugins

    It removed the issues I was having that affected the products/shop formatting issues.

    Also, I noticed the media file settings/sizes have been changed so I had to go in and manually adjust the sizes, un-check the crop button and now I’m regenerating my graphics which will take forever :/ but has to be done

    #109789

    Hi pcprincess77,

    Looks like just a bunch of fixes and I imagine there will still be a few more minor patches that shouldn’t be an issue with installing. You can always double check the changelog to see if there were any changes to functions or anything like that in which case it may have other effects

    2.0.2 - 06/03/2013
    Fix - Frontpage shop when 'orderby' is set.
    Fix - Fix add-to-cart for grouped products which are sold individually.
    Fix - Payment method animation on the checkout.
    Fix - Updated chosen library.
    Fix - Saving of attributes/variations with custom product-level attributes.
    Fix - Include once to prevent class exist errors with widgets.
    Fix - Fixed welcome screen bug shown in updater frame
    Fix - Upgrade if DB version is lower than current.
    Fix - FROM prices now ignore blank strings for variations.
    Fix - Ensure order contents are saved before mailing via admin interface.

    Regards,

    Devin

    #109790

    Hi Devin

    I managed to fix the issues I was encountering with the updates, specifically the products and shop page formatting issues by deactivating all but the woocomerce plugin and reinstalling the replete theme after downloading the files from themeforest.

    I had to go in and adjust the media settings again because they were changed with the update and regenerate them again.

    I’m still waiting for my images to regenerate (swear I’ve spent more time waiting for my thousands of graphics to regenerate on numerous occasions I could’ve built a house from scratch in the amount of time it takes lol) I have upwards of 15k products now so you can imagine how many graphics I have…

    Once the graphics are done, I’ll do a backup, then one by one start activating plugins to see if any of them have become incompatible (crossing my fingers and toes)

    On another note, I have another dev site I’m testing with a completely fresh WordPress, Woocommerce and Replete install and oddly, the styles in the theme options are not working. I imagine there’s something conflicting with the style sheet but I haven’t found the problem yet.

    I’ll take a look using your list above as a reference tomorrow (technically today but my tomorrow) to see if I can pin point the problem. However, if you have any ideas as to what would cause the issue with the theme style not working, I’d be forever grateful :)

    Thanks again guys! So glad I stuck with Kriesi themes. The support here is incomparable….kudos!

    #109791

    With your other dev install…try re-installing Replete again :)

    There was a change this past update with how the theme styling gets generated to remove the big block of inline styling in the main page source. With the issues of getting the files correctly on themeforest there is no telling if you got a slightly correct version or what. Sorry about that, I know its a massive inconvenience this week with constantly having to check if the correct version of the same theme version is in fact the “correct” version.

    Regards,

    Devin

    #109792

    I’m just going to strip it all off the site. I tried numerous times to redo the updates and seeing how it’s for testing compatibility with the new updates and various plugins. It’s no big deal and will save me time to just restart it from scratch :)

    Thanks :)

    #109793

    Odd…I did a completely new WordPress install as well as the woocommerce updated version and the Replete updated files and the styles are not sticking when using the Them options to customize…

    I even tried using the custom CSS and no luck…

    Any thoughts?

    Update: I opened the replete.css in my text editor and copy/pasted the entire style sheet into my custom CSS using the edit CSS option and Bingo! Worked….curious if I’ll have to do this every time I make a style change in the theme options :/

    TBD….

    #109794

    Can we take a look at your site live? That definitely shouldn’t be happening.

    Regards,

    Devin

    #109795

    Sure I haven’t done much more than modify the style sheets .

    I forgot to add that the style sheet I’ve had to keep copy/pasting into the custom CSS is under ->uploads->dynamic_avia (don’t recall seeing this folder previously and the file is replete.css

    http://goo.gl/1foNh

    #109796

    I know I’m not supposed to reply to my own post but I’ve been trying everything to get this issue fixed and literally NOTHING is working.

    I’ve deleted and re-installed Replete at least twice, deactivated woocommerce and then reactivated it, and a host of other mods and nothing is working. I can’t figure out why I can’t get the Theme to recognize my style changes using the Theme Editor, I’ve tried modifying some of the woocommerce stylesheets and that is also not working. No idea what’s going on :(

    All the changes I make are being saved in the replete.css file located under uploads->dynamic_avia

    I have to go in and copy the entire file and then paste it into my custom css file using the edit css option for my changes to be reflected. (sigh ;( )

    #109797

    Hi pcprincess77,

    When I checked your site just now the inspector shows its pulling css from the replete.css file and the custom.css file is empty. Are you still doing the same copy+paste to get the styles into the main page or are you able to do something different now?

    Regards,

    Devin

    #109798

    I actually hadn’t touched any files on that test site since posting the link the other day. So I don’t know why my custom CSS file is empty.

    After reading your post I went in and changed the header style to a bright blue so that it would be easily noticeable when saving the style from the Theme Editor. Also, changed the header background color to #000000 since that would also stand out.

    See the screen shots below and notice they haven’t updated the sites style. The HTML color code is #00ff11 – I’ll need to hop off my iPad and onto my laptop to do a search for the newly added color in the CSS files (iPad FTP program doesn’t let me do a search on the files)

    http://kimpanzarella.com/SCREENSHOTS/IMG_0004.JPG

    http://kimpanzarella.com/SCREENSHOTS/IMG_0005.JPG

    #109799

    Hi,

    Looks like you have 2 custom.css files. I am not sure what that second one is, but it looks like it contains a small part (first 10%) of replete.css

    /dev/wp-content/themes/replete/css/custom.css?ver=1
    /dev/?custom-css=1&csblog=1&cscache=6&csrev=14

    I am not sure what your second custom.css file is because I am not getting it on my fresh installs. Some kind of cache busting query string on it.

    Would you please deactivate jetpack for now, because lately it has been the source of a lot of strange behavior.

    Thanks,

    Nick

    #109800

    That worked on that site. Thank you!

    Still noticing issues with my live site but I have a countdown page plugin enabled for the launch so you can’t access the actual site.

    I’ll check the source code for additional CSS files, but I know I don’t have jet pack enabled on the live site

    #109801

    Okay, so I’m still having issues with the styles and style sheets on my live site. As I mentioned previously I have a countdown plugin configured for the launch so you won’t be able to see the actual site so I’m going to post a couple screenshots with specific issues and I can also copy past the source code into a thread below this one to see if you can see something I’m missing….

    1st issue – On the front page under Featured Products, it’s showing page navigations which wouldn’t be a problem but when I click on any of them it just brings me back to the default 9 products on the Frontpage so I’d like to just get rid of them all together. I tried adding this to the quick CSS section but it’s not working. – See Screenshot #2 below

    .woocommerce-pagination {

    display: none;

    }

    2nd issue – I can’t seem to change the color of the side bar, I could be wrong but I’m almost certain I had it set to a different color than the main content color before doing the updates see Screenshot #1 below

    3rd issue – The partner logos will not use the specified dimensions I’ve set it to which are thumbnails. I’ve tried everything I can think of, regenerated several times etc…nothing is working. Also, can’t remember how to remove the border from the partner logos.

    See Screenshot #3

    I’ll hop back on my laptop and copy paste a snippet of source code…hopefully that will help

    Thanks

    http://kimpanzarella.com/SCREENSHOTS/IMG_0001.JPG

    http://kimpanzarella.com/SCREENSHOTS/IMG_0002.JPG

    http://kimpanzarella.com/SCREENSHOTS/IMG_0003.JPG

    #109802

    Source code from Front Page -

    <link rel="alternate" type="application/rss+xml" title=", Inc » Feed" href="/feed/"/>
    <link rel="alternate" type="application/rss+xml" title=", Inc » Comments Feed" href="/comments/feed/"/>
    <link rel="alternate" type="application/rss+xml" title=", Inc » Home Comments Feed" href="/frontpage/feed/"/>
    <link rel='stylesheet' id='feedburner-email-subscription-css' href='/wp-content/plugins/feedburner-email-subscription/css/widget.css?ver=3.5.1' type='text/css' media='all'/>
    <link rel='stylesheet' id='admin-bar-css' href='/wp-includes/css/admin-bar.min.css?ver=3.5.1' type='text/css' media='all'/>
    <link rel='stylesheet' id='avia-woocommerce-css-css' href='/wp-content/themes/replete/config-woocommerce/woocommerce-mod.css?ver=3.5.1' type='text/css' media='all'/>
    <link rel='stylesheet' id='brands-styles-css' href='/wp-content/plugins/woocommerce-brands/assets/css/style.css?ver=3.5.1' type='text/css' media='all'/>
    <link rel='stylesheet' id='avia-style-css' href='/wp-content/themes/replete/style.css?ver=1' type='text/css' media='all'/>
    <link rel='stylesheet' id='avia-grid-css' href='/wp-content/themes/replete/css/grid.css?ver=1' type='text/css' media='screen'/>
    <link rel='stylesheet' id='avia-base-css' href='/wp-content/themes/replete/css/base.css?ver=1' type='text/css' media='screen'/>
    <link rel='stylesheet' id='avia-layout-css' href='/wp-content/themes/replete/css/layout.css?ver=1' type='text/css' media='screen'/>
    <link rel='stylesheet' id='avia-scs-css' href='/wp-content/themes/replete/css/shortcodes.css?ver=1' type='text/css' media='screen'/>
    <link rel='stylesheet' id='avia-slide-css' href='/wp-content/themes/replete/css/slideshow.css?ver=1' type='text/css' media='screen'/>
    <link rel='stylesheet' id='avia-pf-css' href='/wp-content/themes/replete/js/prettyPhoto/css/prettyPhoto.css?ver=1' type='text/css' media='screen'/>
    <link rel='stylesheet' id='avia-custom-css' href='/wp-content/themes/replete/css/custom.css?ver=1' type='text/css' media='screen'/>
    <link rel='stylesheet' id='avia-dynamic-css' href='/wp-content/uploads/dynamic_avia/replete.css?ver=1' type='text/css' media='screen'/>
    <script type='text/javascript' src='/wp-includes/js/jquery/jquery.js?ver=1.8.3'></script>
    <script type='text/javascript' src='/wp-content/themes/replete/js/avia.js?ver=4'></script>
    <script type='text/javascript' src='/wp-includes/js/comment-reply.min.js?ver=3.5.1'></script>
    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="/xmlrpc.php?rsd"/>
    <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="/wp-includes/wlwmanifest.xml"/>
    <link rel='prev' title='Blog' href='/blog-2/'/>
    <link rel='next' title='Shop' href='/shop/'/>
    <meta name="generator" content="WordPress 3.5.1"/>
    <link rel='canonical' href='/'/>
    <!-- WooCommerce Version -->
    <meta name="generator" content="WooCommerce 2.0.3"/>
    <style type="text/css" media="print">
    #wpadminbar { display:none; }
    </style>
    <style type="text/css" media="screen">
    html { margin-top: 28px !important; }
    * html body { margin-top: 28px !important; }
    </style>

    #109803

    Hi,

    On your dev site. The css code I gave doesn’t seem to be doing its job. Please open up layout.css and find line 2185- which looks like

    #top .widget_nav_menu{
    padding:0;
    overflow: visible;
    }

    and change it to

    #top .widget_nav_menu{
    overflow: visible;
    }

    That changes the layout to look like http://www.clipular.com/c?2814251=iXvHxycV5-cBWd5yqHOn_pLjBRY

    please change your

    .woocommerce-pagination {
    display: none;
    }

    to

    #top .woocommerce-pagination {
    display: none;
    }

    This is the red border around partners

    #top .alternate_color div {
    border-color: #cf0000;
    }

    This is the code for the partner box outline as it is now

    #top .content .slideshow_container, .inner-entry {
    padding: 5px;
    border-style: solid;
    border-width: 1px;
    -moz-box-shadow: 0px 0px 5px rgba(0, 0, 0, 0.15);
    -webkit-box-shadow: 0px 0px 5px rgba(0, 0, 0, 0.15);
    box-shadow: 0px 0px 5px rgba(0, 0, 0, 0.15);
    -moz-border-radius: 3px;
    -webkit-border-radius: 3px;
    border-radius: 3px;
    }

    (change border width to 0)

    Thanks,

    Nick

    #109804

    I disabled the countdown page so you can access the site :)

    live site is

    http://goo.gl/uC0IW

    I’ve recreated the partner logos in photoshop and they look much better with the exception that I can’t get my styles to update so the background is gray instead of white :(

    #109805

    Nick

    I’m not even bothering with the test site at this point. too many bugs on the live site I am concerned with. I posted the live site url above but here it is again

    http://goo.gl/uC0IW

    Thanks

    Side note: the actual replete.css file is not empty nor is the custom.css file in case you click on it and it appears empty…they aren’t :)

    #109806

    Hi,

    Ok

    1) Pagination problem

    Please look in your Settings > Reading settings are – ‘Your latest posts’ http://www.clipular.com/c?2539351=IB582UCFmAeQDTTDbSjcVatLy0U

    2) If that doesn’t work (above) then you can remove pagination with this css

    #top .pagination {
    display: none;
    }

    3) The partner logos are best 209×119. hard crop. I would prep them that size in Photoshop to ensure the crop is made correctly.

    Thanks,

    Nick

    #109807

    Okay, added the snippet to quick CSS and I can now navigate to the various numbers listed below the featured products.

    I did some quick photoshop work on my partner logos but my concern is still the problem with the style sheets. They aren’t reflecting changes I make. For example the alternate content including the partner logos should have a white background #fffff but as you can see it doesn’t show up correctly.

    And I can’t change the color of the sidebars :(

    Can’t figure out what’s going on with the style sheets

    #109808

    Yet another bizarre scenario.

    My style’s randomly updated displaying the white background and a test black background….I didn’t do a single thing except walk away, brush my teeth, prepare for bed and decided to work until I pass out and I clicked on a product and boom, styles set. Now if only I knew how/why I could easily undo the test black alternate content in the main content section. Maybe it will miraculously update in a couple hours…Yowza

    Also, just noticed that the pagination is completely gone from beneath the featured products on the home page, they were functional after adding the snippet of code in the quick css and now they are gone which is fine by me. How bizarre is this!

    #109809

    Hi,

    1) I see a white background on partners http://www.clipular.com/c?2564354=MXZFcXoqSDiuaMc-naw3G7vSEu0 Do you see yours different than that?

    2) Even though it is not recommended, but I would remove custom.css from the entire enqueue process and hardcode it to header.php before the closing of the </head> tag. Otherwise you have no guarantee custom.css will be the very last css file so that via specificity it will counterfeit earlier rules. Right now you are placing css in a file that comes before replete.css in the cascade. So if there are rules in those files that are the same as the rules you add, they will be ignored.

    Create a file called custom2.css and add it to header.php. right before </head>. so the link is hardcoded. Sorry but at this stage with WooCommerce pushing out updates and the water not being settled yet, I would hardcode custom.css and wait till WooCommerce stabilizes so that Kriesi can work with something that doesn’t change on a daily basis. No worries, just a bit more patience please as things settle.

    Thanks,

    Nick

    #109810

    Before I do the unrecommended custom CSS work around I decided to try a couple things.

    I opened my custom.css file in the themes->replete->CSS folder, deleted the contents, saved and uploaded the empty file.

    I opened my site in chrome, inspected the elements and found it was still pulling custom.css and the I clicked on the link in the inspector and all of the contents were still loading even though I deleted everything from the file!!!

    Then, I tried deleting the contents of the replete.css file located under ->uploads->dynamic_avia…went through the same process above and nothing changed. Just went back to my FTP app opened the replete.css file and everything is still in the file but when inspecting the site and clicking on replete.css in my browser, it’s empty!!

    I’ve got some weird cache problem or a ghost file somewhere pointing in the wrong direction…I’m so confused by this right now. I don’t think a new custom css file is going to help but you’d know better than me.

    I just wanted to fill you in on this and see what you think about this before I do anything that will dig my grave any deeper

    #109811

    Hi,

    Regarding the point 1 above , that has been solved because you no longer mention it.

    Regarding cache , Usually the things you describe take place if you use cloudflare. Cpanel maybe?

    Please contact your host and describe the effect you are experiencing. Please either clone the live website or disconnect the plugins during testing. You can probably delete the entire contents of custom.css , since i see little if any changes with it completely removed.

    Please list again what you primary problems at this point are. Disappearing css files are for your host to sort out since root access needed for that.

    Thanks,

    Nick

    #109812

    Just an FYI – I’m waiting for my styles to upload/update before I elaborate on what’s working and what’s not working. Once the mods I made today are visible, I’ll refrain from making any additional modifications until I’ve provided an updated list and given you the opportunity to look at them and reply.

    Hopefully they will magically update any minute now

    #109813

    Hi,

    No problem. We await your directions.

    Thanks,

    Nick

    #109814

    Okay so after much work and digging I think the issues with the style sheets not updating may in fact be due to the worlds worst hosting company, godaddy. From what I’ve found, it appears as though the server is caching everything and mainly due to their Website Accelerator. I switched it to developer mode, cleared the cache and it seemed to work although there are still some background images showing up in the header and the footer that I removed last week prior to doing the process above.

    So for the time being, my styles are the way I want them and hopefully I won’t have to change them again but in case I do, I’ll see what happens and take it from there.

    Regarding my list of issues above, I’ll copy/paste the original list and put the status next to the issue number. I also have another couple issues I need some help with, so I’ll add those to the bottom of the list and mark the status as new (hope that makes sense)

    1st issue – Fixed

    On the front page under Featured Products, it’s showing page navigations which wouldn’t be a problem but when I click on any of them it just brings me back to the default 9 products on the Frontpage so I’d like to just get rid of them all together.

    2nd issue – Fixed

    I can’t seem to change the color of the side bar, I could be wrong but I’m almost certain I had it set to a different color than the main content color before doing the updates see Screenshot #1 below

    3rd issue – Was fixed but now the red border is showing again because I had to change the links for each partner logo and when I saved it the border came back. I originally used the following code in the quick css box and it worked, I’ve tried deleting it, saving, then adding it back and saving again and it’s not removing the red border but it doesn’t look bad and I’ll try deleting the cache in my hosting panel and see if that works.

    #top .alternate_color div {

    border-color: #ffffff;

    }

    This part of question 3 is Fixed – The partner logos will not use the specified dimensions I’ve set it to which are thumbnails. I’ve tried everything I can think of, regenerated several times etc…nothing is working. Also, can’t remember how to remove the border from the partner logos.

    4th issue – Fixed

    footer columns not properly aligned. Now they are.

    5th – New Issue

    I’m trying to create 2 different pages that are listed beneath ‘Shop’ in the main menu.

    I want to have a list of Product Categories display in the main content section of one page called “Product Categories” and the other page is “Product Brands” with a list of products brands in the main content section of the page.

    I can add them in the sidebar but can’t for the life of me figure out how to list them in the pages main content section. Any ideas??

    I’ll stop there for now as I may have one more issue but I want to try a few more things before bothering you guys with it.

    So as of this moment the only issue I need help with is the 5th/New issue

    Thanks for all your help. You guys rock!!

    :)

    #109815

    One more thing….

    Is there a way to remove the posts that have my live sites URL in them on this forum so they don’t show up in google searches please :)

    I tried but I can’t edit the old posts

Viewing 30 posts - 1 through 30 (of 38 total)

The topic ‘WC Version: 2.0.2’ is closed to new replies.