Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #6802


    I’m a bit lost and can’t seem to get the mainpage up.

    When I click “Home” on the menu I’m getting a static page, but want the flashy one with all the graphics on.

    Secondly, the drop down menu under “Services” isn’t sticky – I pull it down, but it disappears when I bring the mouse cursor down.

    I’m using a Mac and same issue with both Firefox and Safari.

    Any ideas? A hierarchy issue?


    My page URL is here:

    I have a temporary redirect setup in whilst I try and sort this out. Dunno if doing that has upset things.


    Have solved the first issue. The redirect index.html was being cached somewhere along the line and didn’t seem to get on well with what WP wanted to do..

    The drop down menu issue still remains. Any ideas?



    1) I’d suggest to build a custom menu. You can create a home link which points to any page you like (i.e. your main url). Go to Appearance > Menu – there you can build custom menu(s). A short tutorial can be found here:

    Also make sure that you didn’t set a static front page (Settings > Reading).

    2) You can set a description text for each menu link. The tutorial above will help you to activate the description option field. If you don’t want to set a description follow the instructions here:


    Aha… if I put in a description under Display Settings > Menu Manager then the menu works OK.

    If you leave the Description blank, then the menu doesn’t work properly. This might be something the author would want to fix, in case users don’t want to put Descriptions in. Or alternatively, are there any special characters you can put in the description field? I’ve tried %20%,
    etc, but these all just get picked up as text and displayed.

    Thanks for the quick response.



    as I said above you can follow the instructions here: if you don’t want to use a description.


    Thanks very much – looks just right now.


    Glad that I could help you :)

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Where has my mainpage gone, plus drop down menu not working?’ is closed to new replies.