Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #244666

    Hi guys,

    I am running into an issue/conflict between Enfold theme and Woo commerce product sorting.

    I’ve already contacted Woo commerce regarding this issue, who suggested I switched to 2013 theme, switching themes resolved the issue. So this issue is directly related to Enfold theme.

    Within Woo commerce, product sorting, I select the option to sort the products to show all the most recent product first. Within Enfold theme, the products get sorted from the oldest to the newest. Switching themes resolves this issue.

    What is the fix for this? Any help you can provide is greatly appreciated.

    Regards,

    Gerry

    #244782

    Here was the answer given by woo-support:

    Hi Gerry

    I have just tested this locally with the latest version of WooCommerce, 2.1.6 and it sorts fine for me when I select sort by most recent.

    I see you have it currently set to default, which uses a combination of the menu order and name, if you want to display the latest products first you must set that option to Most Recent.

    What I am noticing is that you theme has custom orders on the archive pages, so that could also be the cause of the issue as they seem to override this.

    You can do a test and switch to twenty thirteen theme and see if the order works correctly when using that.

    Cheers,
    Gerhard – WooCommerceNinja
    WooThemes Support

    Thanks in advance for helping to remedy this issue.

    Gerry

    #245067

    Hey!

    Afaik Enfold does not change the sort order for products but I’ll mark this thread for Kriesi.

    Regards,
    Peter

    #245179

    Yeah, every other theme that I try it is fine.

    I set the “Sort Order” within Woocommerce Settings, to show most recent products first by default. Enfold is the only theme that is taking that, and sorting from the absolute oldest first.

    I don’t know why, appreciate any input you guys can offer on that.

    #246333

    Hey!

    I just tried this out on my dev site and the ordering is working with the WooCommerce plugin settings. Can we see your main shop page where the issue is happening live?

    Cheers!
    Devin

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.