Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #180596

    Hi,

    i’ve been searching on this forums, found several threads and solutions, tried everything. Haven’t got it working yet.
    So this is:

    . I installed WPML and Woocommerce, set up the languages. My main is spanish.
    . Set up permalinks to “Post Name” at Common Settings + “Shop Base with Category” at Product permalink base.
    . My product tag base is “coleccion”
    . Created a new page to load a Masonry grid with products named “Colección”, also modified Woocommerce Pages setup to point to that page.

    With this setup only throws 404 errors at the single product page. Tried to add more memory on config.php, also adding this to my functions.php: flush_rewrite_rules( false ); , among other solutions i found on the net.

    At this point this is the result: http://keepsports.es/admin/coleccion/

    I’m pretty desperate, any help would be much much appreciated.

    #181081

    Hey Abbe!

    Please create us an admin account and post the login credentials as private reply.

    Regards,
    Peter

    #181217
    This reply has been marked as private.
    #181333

    Hey!

    Please let us know if the issue persist. Post the login details here as a private reply.

    Cheers!
    Ismael

    #181517

    Hi, i finally managed to “fix” this mistake. Among all the solutions I applied, i’m not sure which one did the thing.
    I must say i’m not an expert programmer, but I try as hard as I can. Anyhow, BBDD and php aren’t my speciality

    But, i can tell this
    . Increase the php memory trough hosting admin panel. Make sure Rewrite Rules (or similar) is also activated trough the same panel.
    . Clean installation @ the root of the web server + new BBDD
    . Install WPML, setup the necessary languages. Install Woocommerce + Multilingual (all up to date).
    . Install Woo Pages, created categories. Translated them.
    . Setup permalink structure for WP and Woo at 4 different points: Permalinks & Product (WP), Multilingual (every language on a different path), WPML (one path for each language = es/ en/ ….)

    At the moment i finished, wasn’t working. I gave up and went to sleep, when i woke up thinking i had a hard day before me… SHAZAM, it was working… don’t ask my how.

    Anyway, there is something really wrong:
    1. When the slug is added to the translation strings cause i modified the permalink st., and i do translate them… they are fully ignored.
    2. As soon i turn on the custom post slug translation and i try to translate “products” to other languages trough WPML, it breaks again and throws 404 errors.
    And if i don’t translated, it simply doesn’t shows the correct URL trough all the languages… so enoying.

    Also i’m not sure i added extra not necessary options or slugs translations to my DDBB.

    Credentials:
    http://keepsports.es/wp-login.php
    admin
    uPCtm4kBc9QR

    I would really appreciate any help or direction on how to progress on this.
    I must say this is a great theme that i would like to use on much more other projects, but i’m encountering several problems to set up a stable core.

    Thanks,
    Alberto

    #181940

    Hey!

    I tried to find the problem for 30 minutes now but I’m not sure why it’s not working. I’m pretty sure it’s not a theme issue because I switch the theme to TwentyThirteen (standard WordPress theme) now and saved the permalink settings again and the products still redirect me to a 404 not found page. The original (Spanish) translation works (i.e. http://keepsports.es/coleccion/camisetas/test-es/ ) but the English products, etc (i.e. http://keepsports.es/en/collection/tshirts/test-en/ ) don’t work. Tbh I’ve a hard time to check the settings because I don’t understand Spanish but it seems like WPML is not configured properly. Please contact the WPML support staff and ask them to check your configuration. You can also switch back to the Enfold theme, I activated the TwentyThirteen theme to check if it’s something we can/need to fix on our end or if it’s a WPML configuration/plugin issue.

    Regards,
    Peter

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Woocommerce + WPML + Permalinks 404 error’ is closed to new replies.