Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #192706

    Hello,

    Not sure if I have done something wrong setting WPML up with ENFOLD, but I am having issues with the navigation working. I installed WPML and am trying to have the site work in 13 languages. But when the plugin is active, all my URL’s break with 404′s. All links in the navigation, page links, buttons, everything except the homepage and oddly post pages. Not sure what I need to do to get this working, but any help you can provide would be greatly appreciated.

    The site is http://www.mosfoundation.org.

    Thanks,

    Dave

    #192743

    Hey dmpitzer!

    Please use this plugin: http://wordpress.org/plugins/rewrite-rules-inspector/

    Some possible fix:

    1. Edit the theme settings a few times then save changes.

    2. Go to Settings > Permalinks and change settings a few times then save changes.

    Cheers!
    Ismael

    #192759

    Thanks Ismael for the quick response! Unfortunately, none of these things worked and it is still having the problem.

    Anything else I could try?

    Thanks,

    Dave

    #192806

    I have the same issue.

    #192822

    Hey!

    Please try to replace following line in /wp-content/themes/enfold/config-wpml/config.php

    
    add_action( 'init', 'avia_wpml_register_post_type_permalink', 20);
    

    with

    
    //add_action( 'init', 'avia_wpml_register_post_type_permalink', 20);
    

    Afterwards go to Settings > Permalinks and click the “Save” button.

    Please note that you MUST use the same portfolio slug (Enfold > General Settings > “Portfolio: Enter a page slug that should be used for your portfolio single items” option) for all languages because the theme can’t register the translated permalinks on your server without breaking the existing permalinks. Normally the code I mention above registers new permalink rules for every language but in your case the server probably just stops to process these rules and the end result is that all permalinks won’t work. There seems to be some kind of limitation which doesn’t allow Enfold to register more permalink rules. (See http://www.kriesi.at/support/topic/404-strange-permalink-problems-ii/ ).

    Cheers!
    Peter

    #192957

    Good Morning! Thank you Peter, this fixed the issue and all is working correctly now, sorry I did not see the prior issue in the history.

    Will this be something that I need to comment out every time there is an update to ENFOLD?

    Thanks again!

    Dave

    #193799

    Hi!

    You can also try to put following code into your child theme – then you don’t need to modify the file when you update the theme

    
    add_action( 'init', 'avia_deactivate_permalink_rewrite', 10);
    function avia_deactivate_permalink_rewrite(){
    remove_action( 'init', 'avia_wpml_register_post_type_permalink', 20);
    }
    

    Cheers!
    Peter

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.