Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #255255

    Hello,

    I am currently using this setup: WPML 3.1.5b2 WP3.9 Enfold2.7

    My blog setting are not working, I can not set how many blog post to show, I can not change the style of the blog post lists.
    My Tags, and Categories are not synced. Somehow I can only see my secondaries language category names in enfold post slider section. This is happening when I want to show specific posts, so I would go and select a category, but, I can not find it there.

    Tags will not show up on a post page, for example I want to tag my post with some tags, usually I would start typing and my already existing tags would show up, but it is not happening. And even when I press “show most popular tags” it will tell me that there are no tags.

    What is even more strange. If I want to display tag cloud in a footer, my native languages tags will appear, but will show empty tag cloud for my secondary language. Double checked if my tags are translated and synced. They are.

    Thanks for your support!

    #255713

    Hey PPjev!

    Please create us an admin account – I’ll check issue 1 + 2. Issue 3 + 4 (tag widget and tags) are not theme related because Enfold doesn’t change or “hack” the default tag functions. Please report these bugs to the WPML developers. Note that WPML is still not fully compatible with WP3.9 and I can’t promise that we can fix issue 1 and/or 2.

    Best regards,
    Peter

    #255823
    This reply has been marked as private.
    #255943

    Hey!

    1) I think I found the problem regrading the “blog” issue – you must select the “Use the advance layout editor to build your own blog layout (simply edit the page you have chosen in Enfold->Theme Options as a blog page)” option if you want to use the blog element (which is embedded as advanced layout element into the blog page) instead of the default blog template. If you select the default blog template (i.e. Single Author, etc.) then you can set the number of the post per page on the Settings > Reading page. I now selected the option for the Russian blog: http://ppjev.com/eyes/%D0%B1%D0%BB%D0%BE%D0%B3/?lang=ru and Lithuanian blog: http://ppjev.com/eyes/tinklarastis/ – the other blog pages/settings are not configured yet.

    2) During my test I couldn’t reproduce the “Categories are not synced” issue – all elements (post slider, blog, etc.) listed the translated categories based on the current selected language. If it still doesn’t work on your end maybe the language cookie is missing. Try to clear your browser cache & delete cookies and then go to the editor page to translate it. See: http://www.kriesi.at/support/topic/wpml-homepage-blog-post-not-working/#post-230549
    If this doesn’t help try to deactivate all plugins except WPML and check if the translated categories pop up. If yes a plugin conflicts with WPML and you need to activate them one by one to find the culprit. I.e. here: http://www.kriesi.at/support/topic/problems-adding-avia-button-in-spanish/ the “All-in-One Event Calendar by Timely” plugin caused a conflict.

    Best regards,
    Peter

    #255962

    Hello once again,

    Thanks for your support once again too :)
    You were right, categories are not synced issue was solved by clearing cookies. Now it is working, but my Russian blog entries are not showing up still :( (they dont show up on Home page of russian language. At the bottom I have post slider)

    Thanks!

    #255966

    Hey!

    Yes, I think this issue is also related to WPML. We’ll wait for the final version which is fully compatible with WP3.9 and if it still doesn’t work we’ll look into our code. However we just use a simple query to fetch the posts and I’m pretty sure something is broken with the WPML code. For now I recommend to use an alternative solution or to downgrade to 3.8 until WPML is fully compatible with WP3.9.

    Cheers!
    Peter

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.