Viewing 30 posts - 1 through 30 (of 66 total)
  • Author
    Posts
  • #20660

    Hey Nick,

    I have a problem with the featured images on my translated posts using WPML. I’ve only noticed it in the last couple of weeks. If I make a translation of a post from language A to language B, everything copies over ok (all the images and featured images), but the featured image in the new language B post can’t be clicked, even though it is set to link back to the same post. This works on the original post (language A), just not on the translated post (language B)

    I also realised that I can’t change any of the featured image settings inside the post editing area. If I try to change the linking behaviour or the size it appears in a single page, the changes don’t happen after updating. I haven’t added any new plugins since you last checked the site. Maybe one of the plugin updates (to WPML or another plugin) is causing a problem, or maybe it’s just a WPML setting I have wrong.

    Maybe you can have a look later?

    Thanks.

    rich

    #108503

    Hi,

    I took a look as you know. Please as I wrote, do not use the shopping cart plugin. It is quite dangerous.

    Thanks,

    Nick

    #108504

    I also use WPML and suddenly i cant have featured images in the second language. I can use the featured image to upload em set the page up and when i save the post the images are missing from the slideshow. Maybe its wp 3.5.1 or or the new theme update no idea

    #108505

    By the way all my featured images in the second language are missing since there’s like 250+ pages in my site i cant set up all the images one by one again had no choice but to buy a gallery plugin http://www.backpacktosrilanka.com/de

    #108506

    Hi Artifactual,

    I’m not completely sure but perhaps WPML needs the featured images set for each language. I’ll tag the topic for Peter as I believe he would know for sure one way or another.

    Regards,

    Devin

    #108507

    Actually i always did that separately added the featured images to each language that was a pain but still i did it. Now the issue is i can add more than one featured image to German featured media slider weird maybe this was after the new theme update idk Some help would be really great im like stuck with new entries :( Since i cant add featured media to German articles

    #108508

    You are using the media plugin for WPML? You need that to copy over the featured images from one language to another.

    I get the images copied over but they can’t be clicked afterwards.

    I wonder if there’s something not right in the config.php file for WPML in Shoutbox. Shoutbox doesn’t (didn’t) come with the WPML config files, Nick had to set it up for me because my WPML wasn’t running correctly. I think he got them from another theme. I think the problems started just after that, but I only recently noticed. Could also be a WP3.5.1 thing.

    I just looked at your site and your German featured images don’t click through either. You seem to have lost you slideshows too. Slideshows have to be set up manually in WPML and Shoutbox. You can’t copy over more than one featured image. Something isn’t working between the image admin control panel and WPML.

    Is there another Shoutbox update? I forget which one I’m using now. I think it’s v1.3

    #108509

    I’ve realised that the new shoutbox (v1.4) has a lot of changes in the framework, so I need to fix all those in my theme first. Maybe that will help with this WPML issue, since the update was made quite recently. I’ll post back after updating…

    #108510

    Same here 1.4 but the featured images ive been doing it the hard way manually setting featured images for both languages separately that was such a pain. I think its the wp 3.5.1 update

    #108511

    Well I updated the theme onto a backup site I have and it made no difference at all to the WPML problems. In fact it seems to be throwing up a lot of avia walker errors now, whatever they are. Also updated all the WPML plugins again. Still no joy.

    #108512

    Hey!

    One of the WPML support guys is going to look over my site later. If he discovers anything useful I’ll post it here.

    Best regards,

    Peter

    #108513

    Hi,

    @ramblefish

    I looked for a bit and I think I understand what is happening. When you are duplicating the image, you are not duplicating all the meta data attached to it ( if there should be a button over it, if there should be a link over it etc..)

    The next time you add something, look towards the bottom of the page and you will find this:

    Please change them all to ”copy” before you create the second language page. and create another test where you set them all to translate. because the meta data is not being translated currently. I am not sure if this is backward compatible so please do it with a new dog.


    @Artifactual Please see the above to see if it will help your situation as well and let us know.

    Also WPML v2.7 is out as well as updates for all the additional plugins.

    Thanks,

    Nick

    #108514

    Hi Nick,

    I’ll check what you said and see if it works. I did actually try it after the post was created, but nothing changed so I assumed it was something else. However I’m still unable to alter any of the usual featured image variables in the dashboard (linking properties, size displayed on a single page). Would that be affected by those settings you pointed out, or is that something else?

    Thanks

    rich

    #108515

    Rich,

    Yes. All that is the meta-data that doesn’t get carried over to the translation because of those settings. They need to copy/translate over.

    Thanks,

    Nick

    #108516

    It didn’t work Nick. I tried making a new post with the “copy” and “translate” settings all on. Still the same problem.

    I’m going to try changing some of the settings in the main WPML settings page. There is a whole list of things that can be copied or translated. Some of them seem to be framework settings that don’t show up on the post page, like the ones you pointed out. If that doesn’t work I’ll wait for the WPML guy.

    #108517

    Hi,

    I just spent some time playing with latest brightbox and WPML and If you set those settings i showed in my previous post to duplicate, and then on the translation page you add the image (no need to upload again just select it from media) then both images work correctly.

    Thanks,

    Nick

    #108518

    Hi Nick,

    I’ll try that and see what happens, but it kind of defeats the whole point of the media translation plugin, if you have to reconnect the featured image yourself each time. I think this is what Artifactual was saying above. It seems something has broken with the system since about January.

    I have a whole list of about 50 custom field settings (like the ones you posted above) that can be set to don’t translate/copy/translate in the Translation Management tab of the settings for WPML. Some are not set at all, and once set, you can’t seem to ever go back to not set. I have no idea which ones should be which. It’s really confusing because some are for quite technical settings.

    Thanks anyway…

    #108519

    Didn’t work, Nick. Sorry.

    #108520

    Hi Rich

    I updated to 2.7 today and checked below the post in the “Multilingual Content Setup” and i dont see any of the data you have shown in the image instead i get ” Nothing to configure “

    #108521

    Hi!

    Or do i need to buy the WPML $79 version for this options to appear ?

    Regards,

    Peter

    #108522

    Actually i found a solution for my issue its called WPML Media basically it duplicates featured images into other languages. You can download it in the WPML downloads section

    #108523

    Still its bust as well for some strange reason i cant save the settings in the Slideshow Options. So i cant save options such as Medium insted im stuck with the default small and no rotation

    #108524

    Hi Artifactual,

    I think you are at the same point as me now. The media translation plugin used to work, but now it doesn’t for some reason (although slideshows never translated properly). I’m not sure why you aren’t seeing the custom fields though. They should be either at the bottom of the posts you are translating (you might have to make them visible by turning them on in the dashboard) or in the WPML settings under Translation Management/Multilingual content set up.

    When you translate a post, do your featured images have the mouseover active on both posts?

    rich

    #108526
    #108527

    That’s great! Thanks Nick… look forward to seeing what you came up with.

    rich

    #108528

    I don’t have a section called Translation Management/Multilingual maybe since i have the Multilingual Blog package ($29) maybe i only get it int Multilingual CMS version

    #108529

    Artifactual,

    Yes, I think you need the CMS version which is what I have.

    Nick, I’ll send you a mail and try those settings later. Thanks very much for all your work, I hope it fixes it.

    rich

    #108530

    Artifactual,

    Hmmm… Do you have option to download it in the backend, because I am not sure about difference in the price packages. It would normally be part of the 5 or so plugins offered to download next to each other. Do you see the same settings with the radio buttons?

    Thanks,

    Nick

    #108531

    Rich,

    You saw the video, its almost there, I will play with those setting some more. Because the link back to post option has some issues though all others seem to be working.

    Thanks,

    Nick

    #108532

    Hi Nick

    Nope i don’t see any radio buttons (my multilingual blog version costs $30) maybe the options you mention are only included in the $79 version :(

Viewing 30 posts - 1 through 30 (of 66 total)

The topic ‘WPML issue (?) with featured images’ is closed to new replies.