Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #235951

    Hi,
    I have upgraded to enfold 2.6 and 2.6.1 and the WPML language switcher disappeared from the header.
    I have WP 2.8.1 and WPML Version 3.1.4. this is the site:
    http://www.balducciceramica.com
    Thanks

    #235992

    I go the same issue, this is pissing me off. I have been playing with this WP template for two weeks now, we are ready to launch and this happens. WHY!!!

    #236213

    in the meantime to find a temporary solution I tried to create a shortecode with the plugin “Shortcode Exec PHP” with the php code <?php do_action(‘icl_language_selector’); ?> for the drop-down language switcher, but didn’t work. I’m afraid we have to wait for kriesi support.

    #236225

    There is a similar entry with the same problem here http://www.kriesi.at/support/topic/wpml-language-switcher-disappeared/
    I Inserted the code <?php do_action(‘icl_language_selector’); ?> on the file: includes > helper-main-menu.php an it worked, at least as a temporary solution. Let’s wait for assistance…

    #236230

    Oupps thanks to notice, i will wait to upgrade…
    Your issue is very strange because the language switcher is displayd at http://balducciceramica.com/it/ and also displayed on every page of http://balducciceramica.com/ except the homepage…

    #236236

    Hi!

    I’ll ask Kriesi to fix the issue. I already sent him a patch. For now open up wp-content/themes/enfold/includes/helper-main-menu.php and replace:

    
    if(!empty($nav)) 
    

    with

    
    if(!empty($nav) || empty($nav)) 
    

    and make sure the top menu is active. The next update will enable you to display the menu in the main navigation if the secondary menu is deactivated.

    Cheers!
    Peter

    #236256

    It worked!! Superb job Dude. Thanks

    #236267

    will we expect/wait for a 6.1.2 update?
    thanks

    #236487

    Guy’s I noticed that every time you make an update to the template, lots of setting will revert to default.

    for WPML, you need to reset the placement of language flags. I had to do this for each of my language websites. Go to ENFOLD (ES) > HEADER > EXTRA ELEMENT TAB > (Header Secondary Menu: Secondary Menu in to bar at the right)

    • This reply was modified 7 months, 2 weeks ago by  webguy_ccta.
    #236772

    Hi!

    Glad it works now :)

    Best regards,
    Peter

    #236817

    I’m quite confused : I do not have any file named header-main-menu.php in my wp-content/themes/enfold/includes folder. Could you please explain what happens and how to fix that?

    Thanks

    #236830

    I have the same issue. What happened? Just the select at the fourth column of the footer works. The one in the preheader not. Why?
    *** EDIT ***
    Sorry, hurry makes bad jokes. Using Dude’s trick, it works.

    • This reply was modified 7 months, 1 week ago by  dalcnetsrl.
    #237334

    Hey!

    @Naulet: Please update to the latest version. It will give you new options to modify the header.

    Best regards,
    Ismael

    #237534

    Thank you Ismael and Dude!

    It was, in fact, two differents problems : Firstly, a theme upgrade problem (not all files was upgraded) and secondly a cache problem (with WP-Cache).

    Regards.

    #237716

    i am having the same problem, updated to 2.6.1 and its gone.

    i updated theme files 2-3 through FTP just to make sure, tried various browsers but they do not appear.

    One strange thing also is that if a create a new menu and set it as secondary, enable that in enfold header options and thenenable the option “Display the language switcher in the WP Menu” under WPML>Languages, it shows up along with a new switcher.

    anyone else having problems with it and can provide a solution?

    #238334

    Hi!

    Did you try the temporary fix I posted here: http://www.kriesi.at/support/topic/wpml-language-switcher-disappeared-after-upgrading-enfold/#post-236236 ? The next update will make sure that the langage switcher is displayed even if no secondary menu is selected.

    Cheers!
    Peter

    #238518

    OK thanks i will wait for the update then.

    Maybe you can add it as a checkbox in header options (display WPML language switcher on top left/right.)

    Thanks.

    #239226

    Hi!

    I chose an automatic solution. If the top bar is activated (i.e. because of the phone number option, social icons or secondary menu) the flags will be displayed in the top bar. If the top bar is not activated the flags will be displayed on the right side if the main menu. If an user wants to display the flags in the main menu although the top bar is activated this filter code (insert it into your child theme functions.php):

    
    
    add_filter('avf_wpml_language_switcher_position', 'avia_change_lang_switcher_position', 10, 1);
    function avia_change_lang_switcher_position($position)
    {
        return 'main_menu';
    }
    

    allows him to change the position from the top bar to the main menu.

    Best regards,
    Peter

    #239234

    This is something that will be applied on the next update? I still think that a choice of a dropdown under header elements would be the way to go.

    WPML Language Switcher

    1. Show top left
    2. Show top right
    3. Show right of main menu
    4. Show left of main menu
    5. Dont show

    If enabled then the following extra options will appear:

    WPML Language Switcher Style

    1. Flags
    2. Text
    3. Flags with native text
    4. Flags with display text

    Just my two cents :)

    • This reply was modified 7 months, 1 week ago by  george.
    • This reply was modified 7 months, 1 week ago by  george.
    #239253

    Hey!

    Yes we’ll see. If more user request advanced options we’ll look into it. However we didn’t get a lot of customization requests for the WPML language switcher in the past (maybe 5-10 overall) and I think the majority is happy with the default design. We must find a compromise between flexibility, usability and performance and imo adding these options will have a negative impact on the usability and performance and thus I’d like to go with my solution for now.

    Regards,
    Peter

    #239258

    dont get me wrong…my mind is surely not on the same level as yours. I am outside theming and you are in it, so you know best!

    Enfold is the best theme out there and i love it :) whatever you end up doing is fine with me :)

    #239265

    @Dude,
    I have tried your solution proposed in #236236, but it doesn’t seem to work for me.
    Have you got another idea?

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘WPML language switcher disappeared after upgrading Enfold’ is closed to new replies.