Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #240201

    Hi all, I’m getting duplicate flags on the main menu. This happened after updating to version 2.6.2

    Any help is appreciated.

    #240917

    Hi Jorge!

    Have you tried to remove it from the WPML options page ? this should let you remove the Espanish flag in there.

    Best regards,
    David

    #240939

    Hi David, yes I tried that too and can’t remove the extra flags.

    #241109

    Hey!

    Go to WPML > Languages and deselect the ” Display the language switcher in the WP Menu” checkbox.

    Cheers!
    Peter

    #241155

    Hi,
    deselecting the ” Display the language switcher in the WP Menu” works, but it’s just a workaround, infact it’s not the way WPML plugin is meant to work.

    I had the same problem and solved it disabling “MailChimp List Subscribe Form” plugin, please read here for futher infos: http://www.kriesi.at/support/topic/enfold-wpml-translated-categories-post-slider-not-working-properly/

    Hope it can help!
    Alessio

    • This reply was modified 4 months, 1 week ago by  aledef.
    • This reply was modified 4 months, 1 week ago by  aledef.
    #241337

    Hi Dude, I did that and now I only see the flags without language text. I want to use the dropdown option.

    @Alessio,I’m not using Mailchimp and actually the rest of the plugins I intent to use are disabled so it has to be another way to fix this.

    I don’t think it is WPML plugin since it was working correctly before updating enfold to the latest version.

    I downloaded a fresh copy of the theme and uploaded via FTP, it did not help.

    Any other tip in order to get the dropdown working correctly?

    Thanks guys.

    #241343

    Hi all,
    Same problem for me. Resolved with this add in custom CSS :

    .language_flag {
    display: none;
    }

    - Add this if you doesn’t want display flags.
    - Use the Dude’s answere if you doesn’t want display “language switcher” but only flags.
    - Do nothing if you want display “language switcher” AND flags :o)
    - You cn also add flags in the language switcher…

    Hope that help.

    Best regards,

    Jul…

    #241355

    Hi Jorge,
    try this:
    - Go to Wp admin panel and verify it is seet to your main language from Wp topbar dropdown menu, if it is not, switch it to main lang
    - Go to WPML -> Languages
    - Check the box and select your option in the “Display the language switcher in the WP Menu” dropdown menu
    - Save
    - Switch it to a different language from the Wp topbar dropdown menu
    - Check the box and select your option in the “Display the language switcher in the WP Menu” dropdown menu (now you should see translated menus in dropdown)
    - Save

    It worked for me, no more duplicated flags!

    There is still something not working properly in WPML admin panel, anyway.
    If after following those steps you switch bak to your main lang
    the “Display the language switcher in the WP Menu” dropdown will be unselected
    because your last selection was in a different lang, wich is not available.

    Not easy to explain actually :) hope it is clear enough.

    Alessio

    • This reply was modified 4 months, 1 week ago by  aledef.
    #241357

    Did not work for me Alessio. If I do that in English, I get the drop down and the flags. When I switch to Spanish and change the settings as described it does not change anything on the front end.

    I already open a ticket at WPML to see if there’s another workaround. I’m sure there’s something to do with the template.

    Thanks for your help.

    #241548

    Hey!

    Since 2.6.2 Enfold will add the flags to the main menu if WPML is activated and no top bar (secondary menu) is activated. If you don’t want to show the flags in the main menu insert this code into your child theme:

    
    add_action('after_setup_theme','avia_remove_main_menu_flags');
    function avia_remove_main_menu_flags(){
            remove_filter( 'wp_nav_menu_items', 'avia_append_lang_flags', 20, 2 );
            remove_filter( 'avf_fallback_menu_items', 'avia_append_lang_flags', 20, 2 );
    }
    

    Regards,
    Peter

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.