Tagged: ,

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #194853

    Hello.

    I have some issues with WPML working with this theme. Our production page http://www.sanandresusa.org is currently in Spanish. On our Beta site (beta.sanandresusa.org) we have started with a fresh install and added the English pages first before adding the Spanish pages. After adding the Spanish content and verifying the permalinks are in “http://penatechnologies.com/sample-post/” (Post name) and the languages as directories (beta.sanandresusa.org – EN, beta.sanandresusa.org/es – ES) the home page for both languages appears but then any other page for the English give me 404s. When I switch to Spanish they all work except ‘Escuelas’ and ‘Conócenos’ redirect to the same page ‘Escuelas’ (which it should NOT do).

    I have spent the better part of two weeks trying all sorts of changes, reading forums and message boards on both this site, WPML‘s site and whatever Google gives me no success.

    I am at my wit’s end. Please help!

    Version Information:
    Incarnation 1.3
    WPML Multilingual CMS 3.0.1
    Select WPML String Translation 2.0.1
    Select WPML Translation Management 1.9.1

    Other plugins installed are:
    bbpress 2.5
    Installer 0.7.1
    MailChimp for WordPress Lite 1.4.6
    ManageWP – Worker 3.9.28
    Sidebar Login 2.6.0
    User Access Manager 1.2.4.3
    Wordpress Importer 0.6.1
    Wordpress SEO 1.4.19

    #195046

    Hi ChepsChups!

    Please try to flush the permalink settings a few times. Go to Settings > Permalink, change it a few times. Please use this plugin to perform a soft flush of rewrite rules: http://wordpress.org/plugins/rewrite-rules-inspector/

    Regards,
    Ismael

    #195114

    Hello Ismael,

    Thanks for the response.

    Unfortunately nothing changed. I spent a good 2 minutes changing permalinks and saving, then spend about a minute or two just clicking on flush rules and still having issues.

    If you need access to the beta server please let me know.

    Please help!

    • This reply was modified 4 months, 2 weeks ago by  ChepsChups.
    #195233

    Hello
    I have exactly the same problem … who have a solution ?
    thanks

    #195244

    Hey!

    Please try to add following code to the functions.php file

    
    add_action( 'init', 'avia_deactivate_permalink_rewrite', 10);
    function avia_deactivate_permalink_rewrite(){
    remove_action( 'init', 'avia_wpml_register_post_type_permalink', 20);
    }
    

    - and go to Settings > Permalinks and click the “Save” button to flush the permalinks. Does it solve the issue?

    Best regards,
    Peter

    #195248

    Hi Peter,
    thanks for your reply.
    So i add the code and flush the permalink but always the same :

    http://95.215.225.21/~interrel/la-plateforme/comite/

    IF you want a access you can tell me.. i try many things ..:-(

    best regards
    franck

    #195284

    Hi Peter,
    I see my client tomorrow, and i need to found a solution. Can you help us as soon as possible. ?
    Thanks a lot

    #195713

    Dude,

    After adding the code to the bottom of the functions.php, it seems to finally pull up the English translation. However, in the Spanish translation “Conócenos” (SAUSA -> Conócenos) and “Escuelas” keep redirecting to same page “Escuelas”

    Should I delete the “Escuelas” page and redo it?

    Making good progress, thanks :)

    To the others following this thread:
    I currently have the permalinks as “Post Name” and installed the rewrite plugin Rewrite Rules Inspector (1.2.1). I also have “Different languages in directories” checked under WPML -> Languages. No other box or radio button is toggled. My “Languages Order” is English, Spanish.

    I edited the functions.php file through the Appearance -> Editor page and selected “Theme Functions” (functions.php) and copy-pasted the code on the very bottom:

    // deactivate default theme seo if third party plugin is used. Currently supported plugins: Yoast WP SEO and All in One SEO
    if(defined('WPSEO_VERSION') || class_exists('All_in_One_SEO_Pack')) $avia_config['deactivate_seo'] = true;
    
    /* **** ADD CODE AFTER THE ABOVE LINE *** */
    
    /* Per forum thread: http://www.kriesi.at/support/topic/wpml-showing-404-errors-on-main-language/#post-195244 */
    add_action( 'init', 'avia_deactivate_permalink_rewrite', 10);
    function avia_deactivate_permalink_rewrite(){
    remove_action( 'init', 'avia_wpml_register_post_type_permalink', 20);
    }

    I then went to Settings -> Permalinks, selected “Post Name” and “Save Changes” then went to Tools -> Rewrite Rules and selected “Flush Rules” (this appears only if you have the rewrite rules plugin installed) and it worked.

    Please make sure you followed WPML suggestions regarding editing the .htaccess to allow language directories: http://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

    • This reply was modified 4 months, 2 weeks ago by  ChepsChups. Reason: Added information for thread followers
    #195911

    Concurrent thread with WPML: http://wpml.org/forums/topic/wpml-404-errors-on-main-language/

    Regarding the two translated pages “Escuelas” and “Conócenos” redirecting to “Escuelas” that is still an ongoing issue. I have deleted both translated pages, purged the trash and redid them, Conocenos first and then Escuelas and it still redirects to Escuelas. As a test I deleted just Escuelas and Conócenos redirects to “Descargar Archivos” (downloads). I think this behavior is pointing to a random page and it is quite frustrating.

    #196918

    Hey!

    Please check the permalinks of the “Conócenos” and “Escuelas”. I guess that a category and a page share the same slug and if you remove and then wordpress will link to the archive page instead of the page which uses the same slug/permalink.

    Cheers!
    Peter

    #197424

    After deleting all the templates from template builder and redoing them and verifying all pages are pointing correctly, it seems to work.

    Hopefully the others following this thread can find some use of this information.

    #197959

    Hi!

    Glad you found a solution :)

    Regards,
    Peter

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘WPML showing 404 errors on main language’ is closed to new replies.