Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #276297

    Here’s an example of how our page structure should (and used to) look:

    http://www.avatron.com/apps/air-display

    the “air-display” page has the “Apps” page listed as its parent.

    But here’s what happens when you go to that page now:

    http://www.avatron.com/3-apps/air-display

    The “3-apps” is the problem.

    I created the problem when I cloned the “apps” page to modify it with changes I intended to publish later.
    Long story short, I realize that isn’t the right way to do that, and I *thought* I ended up making the changes to my original page, but now I’m at a loss for what to do next.

    Things I’ve tried:

    • Emptying the trash to make sure the “3-apps” page is gone gone
    • Purging all pages from the cache
    • Temporarily assigning a different parent to my child pages
    • Deleting all the menus and starting over
    • Cursing under my breath
    • Cursing out loud
    • Pleading with any higher power
    • Reading lots of WordPress forums looking for ideas
    • Any insight is very welcome.

    #276326

    Hi steed!

    Have you tried praying to Justin Bieber? :D

    After you purge the trash, try to go Settings > Permalinks then click the “Save” button once to flush the permalinks. If that doesn’t work, try to delete the .htaccess file then flush the permalink settings again.Edit the page then look for the Permalink below the title. Another thing that you can do is to click on the Screen Options while editing the page then enable and change the slug settings.

    Regards,
    Ismael

    #276327

    Hi!

    I tried to change the slug of the Apps page to apps but it somehow break the child pages. You just need to change it back to 3-apps to turn it back. Did you install any redirect plugin? Please try to remove it then change the slug and flush the permalink settings again.

    Cheers!
    Ismael

    #276365

    Hi Ismael,
    I forgot to mention on my list of previously tried solutions that I did try:

    • set permalinks back to default settings, save, purge cache, reset back to “Post name”, save, purge cache
    • I did NOT YET try

    • Praying to The Bieb

    I’ll commence that activity right away. In the meantime, I’m not clear what you meant in your next suggestion:
    You just need to change it back to 3-apps to turn it back. Did you install any redirect plugin? Please try to remove it then change the slug and flush the permalink settings again.
    I went into the front page editor, checked the “Slug” box in Screen Options, but it still only gives me the option to “View Page” rather than offering me the ability to edit the permalink.
    And if I go to any of the pages with “Apps” listed as a parent, I still can’t change the /3-apps/ part of the permalink.
    As to your question about redirect plugins, I don’t think I have anything like that running.

    Thanks for your help so far.

    #276417
    This reply has been marked as private.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.