If you have troubles since the update to WordPress 4.5 please read this post before opening a new thread.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #21323


    i’ve tried share my video in HD quality but it doesn’t work. Please don’t tell me that i can’t share my video in HD quality with code ;vq=hd720 after youtube URL. If not, how can i share my video in HD quality?:( My web is build on video posts and video tutorials, i need HD quality :(

    Thank’s a lot!


    Hi Lamaci,

    At which point are you trying to add the HD attribute? Is it in a regular post or in a portfolio item?




    Hello Devin,

    it’s portfolio item. If i can’t add my video in HD is there any option to change video player?



    Hi Lamaci,

    It looks like the hd parameter is deprecated for embeds and can’t be forced anymore. I tried a few tests but even just embedding an iframe using youtubes default code and adding the hd=1 parameter doesn’t seem to do it anymore.

    You may want to just make a note to remind everyone to turn HD on.





    Afaik Youtube will use embed the right video version based on the screen resolution: http://productforums.google.com/forum/#!category-topic/youtube/ (Purchase code hidden if logged out) /ho_J-fqcprk

    Best regards,



    Hello Dude,

    yes i understund but how can i change my video player size? Because you can only add video without any URL config. If you put URL with any changes you get this: http://imgupload.sk/images/1/m/1mvzpm87eidbqkpifd2u.png

    How can i set my video to right size in portfolio section also in index slider?




    Hi Denis,

    The size is set based on the container size. So in the portfolio, it adjusts to the grid size there, in the slider it adjusts to that size. Even then it wouldn’t necessarily auto set the video to HD since the HD is only set at almost fullscreen size.

    If you absolutely need to force HD, then I would suggest not adding the video to the theme slidshow areas and instead just embed it into the regular visual editor and set the iframe size to the full page width or content width of the page its set on.




    I’ve try this embed code with write URL but nothing work… Also i’ve try embed on my blog with right code but still my video is sharing only in 360p :X… any ideas?


    It looks like the new iframe way no longer supports forcing HD at all anymore. This was a change from google/youtube so if want to force HD, you would need to use the old embed code.




    After 2 hours i found solution – sharing youtube in HD in regular visual editor ALSO in PORTFOLIO and SLIDER!

    here is the right code for everyone: (youtube HD)

    <iframe src=”https://www.youtube.com/embed/Esj5juUzhpU?vq=hd720″ width=”940″ height=”480″></iframe>

    Also code with different color player and HD stream! (working)

    <iframe src=”https://www.youtube.com/embed/Esj5juUzhpU?theme=light&color=red?vq=hd720″ width=”940″ height=”480″></iframe>

    Thank you,



    Glad you were able to find a working solution! I only saw that the hd=1 or hd=0 method was no longer supported and not that you could use video quality as a parameter for the iframe so I’ll take note of it :)



Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Youtube HD’ is closed to new replies.