Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #9501

    Hi there,

    On my website using the Angular theme, I used the class=”nolightbox” to disable a YouTube link from opening in a lightbox. However, when I hover over the image that contains the link to YouTube, I get a video hover effect. You can see what I mean by checking out this link and going to the footer to the image that says, “subscribe on YouTube” http://notashamedofthegospel.com/blog/

    May I please ask you how I can get that hover effect disabled?

    Thanks,

    Peter

    #64900

    Hey,

    open up js/avia.js and delete following code:

    //activates the hover effect for image links
    if(jQuery.fn.avia_activate_hover_effect)
    jQuery('body').avia_activate_hover_effect();

    #64901

    sorry, I tried that but it didn’t work for me. Am I doing something wrong?

    I did it in my staging area, here is a link to a sample page with the YouTube hover affect in the footer http://dev.notashamedofthegospel.com/blog

    #64902

    I have the same issue for both YouTube links and Vimeo links (see visionhouse.pro) in the footer. I want to be able to launch light boxes in some places, but the footer links should not get hijacked into a lightbox… any help here?

    #64903

    So , is there a solution for this?

    #64904

    Hey,

    you just need to add the “noLightbox” class to your social icons. If you have access to the php/html code simply add “noLightbox” without “” to the link class, otherwise you can use javascript. Open up js/avia.js and replace:

    jQuery(document).ready(function(){

    with:

    jQuery(document).ready(function(){

    jQuery('a.social-icon').addClass('noLighbox');

    #64905

    I am having a similar problem actually….and can’t seem to fix this.

    I have added the class in header.php and edited the javascript to no avail. I am using the “dribble” social icon as a YouTube link and have successfully changed the icon, but still get a pretty photo attempt at opening up the url, and it then gives an alert saying “Image cannot be loaded. Make sure the path is correct and image exist.”

    Can you provide what the header.php code should look like with the class of noLightbox in place? maybe I am not putting it in the correct spot.

    I really need to fix this.

    #64906

    Hi rmorson,

    The final line for making dribble into youtube would be:

    if($dribbble = avia_get_option('dribbble')) { $social ++; echo "<li class='dribbble noLightbox'><a href='http://youtube.com/".$dribbble."'>".__('Follow us on dribbble', 'avia_framework')."</a></li>"; }

    Then in my dribble field in the theme options I put user/myusername .

    Regards,

    Devin

    #64907

    Hi Devin,

    That worked great. Thanks for the quick reply.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘YouTube Links With Class="nolightbox" has a hover effect’ is closed to new replies.